Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28499 - [passenger] Build Nginx helper agent

Attached to Project: Community Packages
Opened by K M Ganesh (kmganesh) - Saturday, 18 February 2012, 11:08 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 14 March 2012, 13:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
passenger package doesn't build the Nginx helper agent. Since It is listed as optional deps for nginx package and nginx also builds the passenger module into its binary. Installing nginx and passenger and starting nginx on a rails project will give out an error
Unable to start the Phusion Passenger watchdog because it encountered the following error during startup: Unable to start the Phusion Passenger helper agent because its executable (/usr/lib/passenger/agents/nginx/PassengerHelperAgent) doesn't exist. This probably means that your Phusion Passenger installation is broken or incomplete. Please reinstall Phusion Passenger (-1: Unknown error)

Fix:
in passenger PKGBUILD build()
rake nginx

Additional info:
packages: passenger 3.0.11-1, nginx 1.0.12-1

Steps to reproduce: (as root)
pacman -S passenger nginx
gem install rails
cd /srv/http
rails new nginx_test
nginx -c /tmp/nginx.conf

/tmp/nginx.conf
daemon off;
user http;
worker_processes 1;

error_log /dev/stderr info;

events {
worker_connections 1024;
}


http {
passenger_root /usr/lib/passenger;
passenger_ruby /usr/bin/ruby;

types {
text/html html htm shtml;
text/css css;
text/xml xml;
image/gif gif;
image/jpeg jpeg jpg;
application/x-javascript js;
application/atom+xml atom;
application/rss+xml rss;

text/mathml mml;
text/plain txt;
text/vnd.sun.j2me.app-descriptor jad;
text/vnd.wap.wml wml;
text/x-component htc;

image/png png;
image/tiff tif tiff;
image/vnd.wap.wbmp wbmp;
image/x-icon ico;
image/x-jng jng;
image/x-ms-bmp bmp;
image/svg+xml svg;
}

default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for" "$document_uri"';

access_log /dev/stdout main;

sendfile on;

keepalive_timeout 0;

server {
listen 127.0.0.1:3001;
rails_env "development";
root /srv/http/nginx_test/public;
passenger_enabled on;

}
}

This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 14 March 2012, 13:43 GMT
Reason for closing:  Fixed

Loading...