Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28480 - [xcompmgr] does not draw shadows in openbox

Attached to Project: Arch Linux
Opened by shyn (shyn) - Friday, 17 February 2012, 08:50 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 20 May 2012, 09:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Xcompmgr does not draw shadows in openbox after upgrade to 1.1.6-1 version. It's started without errors, but doesn't affect to the windows (no shadows beside).


Additional info:
xcompmgr 1.1.6-1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 20 May 2012, 09:34 GMT
Reason for closing:  Upstream
Additional comments about closing:  I'm CC'ed to the upstream issue.
Comment by John Lock (opt1mus) - Friday, 17 February 2012, 13:19 GMT
If this doesn't prevent your system from functioning, then surely the severity of this is low, not critical.

https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines#Severity
Comment by shyn (shyn) - Friday, 17 February 2012, 13:41 GMT
My mistake, sorry. It's possible to fix this?
Comment by Andreas Radke (AndyRTR) - Friday, 17 February 2012, 15:12 GMT
If you show us the fix it's possible. Go and talk to the upstream devs. It's not a packaging bug for sure.
Comment by Guilherme (GUiHKX) - Saturday, 18 February 2012, 02:35 GMT
First off, I'm sorry for my bad english. I was with the same problem after upgrading xcompmgr 1.1.5 to 1.1.6-1. The temporary solution was downgrading it. I used ABS to compile both versions (1.1.5 and 1.1.6-1) and the problem only occurs with 1.1.6-1. The problem is that windows and menus borders gets unshadowed. (I'm using Awesome WM not OpenBox).
Comment by Andreas Radke (AndyRTR) - Saturday, 18 February 2012, 15:30 GMT
please file an upstream issue when fdo is up again.
Comment by mattia (nTia89) - Sunday, 19 February 2012, 11:12 GMT
can you tell how do you launch xcompmgr, which switch do you use ?
Comment by Stephanie Schilling (Stephanie) - Sunday, 19 February 2012, 11:33 GMT
I have the same issue.

Version is 1.1.6.1

I launch it with
xcompmgr -cf & (in ~/.config/openbox/autostart)

I get no error-messages when I start it from the terminal.
Comment by mattia (nTia89) - Sunday, 19 February 2012, 12:49 GMT
i confirm the issue: with latest version (1.1.6) xcompmgr don't draw shadows
i compiled myself the 1.1.5 version and it seems to work ....

can you confirm ?
Comment by Stephanie Schilling (Stephanie) - Sunday, 19 February 2012, 13:14 GMT

Downgraded to xcompmgr 1.1.5-1 and it draws shadows.

Where would I have to file an upstream-bugreport for it ? At http://xorg.freedesktop.org?
Comment by Stephanie Schilling (Stephanie) - Sunday, 19 February 2012, 13:40 GMT
Opened a bug-report at https://bugs.freedesktop.org/show_bug.cgi?id=46285

I hope that was the right place.
Comment by mattia (nTia89) - Sunday, 19 February 2012, 14:25 GMT
perfect !

Loading...