Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28479 - [llvm] LLVMgold.so need to be installed in /usr/lib/bfd-plugins as well

Attached to Project: Arch Linux
Opened by darkraven (darkraven) - Friday, 17 February 2012, 06:03 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 26 February 2012, 18:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

LLVMgold.so need to be installed in /usr/lib/bfd-plugins as well, otherwise compile using clang with the -flto options won't work.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 26 February 2012, 18:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in llvm-3.0-2.
Comment by Jason William Walton (jasonww) - Friday, 17 February 2012, 14:00 GMT
Works for me.
Comment by darkraven (darkraven) - Saturday, 18 February 2012, 04:37 GMT
Steps to reproduce:

echo 'main(){b(1);}' > a.c
echo 'b(int a){printf("%d\\n");}' > b.c
clang -flto b.c -c
clang -flto a.c -c
ar q b.a b.o
ranlib b.a
clang -flto a.o b.a

Would result in :

/usr/bin/ld.gold: error: b.a: no archive symbol table (run ranlib)
lto-llvm.o-3eigN7:ld-temp.o:function main: error: undefined reference to 'b'
clang: error: linker command failed with exit code 1 (use -v to see invocation)

If there is no LLVMgold.so in /usr/lib/bfd-plugins

Loading...