Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28459 - [dansguardian] not working any more

Attached to Project: Arch Linux
Opened by roberto porcaro (porcaror) - Wednesday, 15 February 2012, 16:55 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 11 September 2012, 23:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Kevin Piche (kpiche)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
After upgrading to the new Dansguardian version it is not possible to browse anymore.
If for example I try the url www.aarchlinux.org in firefox it doesn't work. With elinks I obtain the following:

Unable to retrive proxy://192.168.2.253:8080/http://www.archlinux.org/:

Before the upgrade all was right.

Can you help me?

Error reading from socket
Additional info:
* dansguardian 2.10.1.1-3 squid 3.1.16-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 11 September 2012, 23:19 GMT
Reason for closing:  Won't fix
Additional comments about closing:  dansguardian is no longer in repos
Comment by Paul Gideon Dann (giddie) - Thursday, 16 February 2012, 15:04 GMT
This seems to be related to the upgrade of PCRE. Downgrading PCRE to 8.21.1-1 fixes Dansguardian, but of course it breaks a load of other stuff. I've tried rebuilding Dansguardian 2.10.1.1-3, but that doesn't fix it.
Comment by Paul Gideon Dann (giddie) - Thursday, 16 February 2012, 15:31 GMT
A temporary workaround is:

# sudo pacman -U /var/cache/pacman/pkg/pcre-8.21-1-x86_64.pkg.tar.xz
# mkdir ~/pcre-old
# cp -a /usr/lib/libpcre* ~/pcre-old
# cp -a /lib/libpcre* ~/pcre-old
# ln -sf libpcre.so.0 ~/pcre-old/libpcre.so
# sudo pacman -S pcre
# sudo /etc/rc.d/dansguardian stop
# sudo LD_LIBRARY_PATH=~/pcre-old /usr/sbin/dansguardian

This does the trick for me. The last two steps will need to be repeated every time the computer is rebooted.
Comment by roberto porcaro (porcaror) - Friday, 17 February 2012, 12:57 GMT
Thank you. I have a question:
I have dansguardian on the server of my school, do you think that using you trick on the server the clients will work?
Thank in advance
Roberto
Comment by Paul Gideon Dann (giddie) - Friday, 17 February 2012, 13:30 GMT
Yes, the trick should work for any application of Dansguardian, I think.
Comment by Michael Boratko (process91) - Friday, 17 February 2012, 20:19 GMT
Thanks for the help with this issue Paul, I was banging my head for a while with this. I don't know if this is an appropriate workaround as well, but to prevent having to manually stop/start dansguardian every time (as it is actually running on my desktop PC), I saved the following script as /etc/rc.d/dansguardian_pcre_fix:

rc.d stop dansguardian
sleep 1
LD_LIBRARY_PATH=/home/<USERNAME HERE>/pcre-old /usr/sbin/dansguardian

and then added it to the list of daemons in /etc/rc.conf after dansguardian. Once the issue is fixed, just remove this file and the reference to it in /etc/rc.conf.
Comment by Paul Gideon Dann (giddie) - Sunday, 19 February 2012, 17:36 GMT
I'd suggest simply editing the /etc/rc.d/dansguardian script to add the LD_LIBRARY_PATH variable. It'll get overwritten when dansguardian is next updated, at which point it'll hopefully be working again anyway :)
Comment by roberto porcaro (porcaror) - Monday, 20 February 2012, 15:36 GMT
Thank you indeed. Now it works with one exception: I use two filtergroups, but now it seems to work only the filter for the default group (the first one):
Comment by Paul Gideon Dann (giddie) - Monday, 20 February 2012, 16:13 GMT
I'm afraid I can't offer any suggestions for that, since I don't use that feature, although it does seem odd that it would stop working despite using the old libraries. Have you tired downgrading to Dansguardian 2.10.1.1-2? Hopefully the maintainer (Kevin Piche?) will have a chance to look into this soon.
Comment by roberto porcaro (porcaror) - Monday, 20 February 2012, 20:43 GMT
You are right. In working with the configuration file I commented the option for activacting filters. Sorry for that and thank you for your reply.
Thanks
Roberto
Comment by Gilberto Tin (gtinjr) - Sunday, 26 February 2012, 14:39 GMT
I spent the whole afternoon troubleshooting my network yesterday. I thought it was a problem with the iptables in the router or the iptables rules in the server. Until I tried to connect directly to squid on port 3128 bypassing dansguardian and everything workded.

I also noticed that if I connect browser to dansguardian on port 8080 bad sites gets banned (probably blacklist) but good sites do not show. I ran tshark on port 8080 and I could see incoming requests. When I ran tshark to monitor squid on port 3128 and browser pointing to proxy on dansguardian port 8080 then nothing gets captured by tshark. It seems that dansguardian is not forwarding the requests to squid. I have not tried to downgraded pcre yet.
Comment by Gilberto Tin (gtinjr) - Sunday, 26 February 2012, 20:24 GMT
Thanks Paul!!! I followed your work around steps and added the library path in dansguardian start/stop script and now everything is working.

Loading...