Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28450 - [xfwm4/qt4] fullscreen results in xfce-panel still showing

Attached to Project: Arch Linux
Opened by . (Thralas) - Wednesday, 15 February 2012, 13:45 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 13 April 2013, 21:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When Qt requests a window to go fullscreen, and (!) the window is currently maximized, xfce-panel is drawn on top of the 'fullscreen' window in either of two scenarios:

1. As soon as a GUI element in Qt has its visibility changed (eg. menubar hidden)
2. If a GUI element is programatically hidden right before requestion fullscreen, the issue immediately manifests itself

Note for 2: interestingly, if a GUI element is hidden 'manually' (eg. by doing so as a key is pressed) and fullscreen is requested using another keypress, xfce-panel is NOT drawn on top of the fullscreen window.

A real-world occurance of this bug is VLC: requesting fullscreen with a maximized window results in xfce-panel showing on top of the video.

I've attached a testcase which can be used to reproduce the issue (requires python2-pyqt)

Versions at time of writing are: xfwm 4.8.3 Qt 4.8.0

Additional notes:
- I've been able to narrow occurence of this bug down to Qt/Xfce, but am not entirely sure which of the two is responsible. The fact that the issue doesn't seem to be reproducable on non-Xfce desktops suggests xfwm might be at fault.
- I was unable to reproduce this on a Xubuntu 11.10 livecd instance
- This is probably an upstream bug, but as it is unclear which component is to blame, I've reported it here
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 13 April 2013, 21:32 GMT
Reason for closing:  Upstream
Additional comments about closing:  Please follow the upstream report (linked in the last comment).
Comment by Jelle van der Waa (jelly) - Wednesday, 11 April 2012, 19:47 GMT
So still an issue?
Comment by . (Thralas) - Thursday, 12 April 2012, 12:29 GMT
Just verified; unfortunately it is.
Comment by Evangelos Foutras (foutrelis) - Sunday, 13 May 2012, 16:18 GMT
Possibly related upstream bug report: https://bugzilla.xfce.org/show_bug.cgi?id=8563

Loading...