Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28441 - The new nvidia driver causes a bug in Gnome-shell

Attached to Project: Arch Linux
Opened by Nassim K. (blueicefield) - Wednesday, 15 February 2012, 09:07 GMT
Last edited by Ionut Biru (wonder) - Friday, 23 March 2012, 08:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 35
Private No


It's seems that the new nvidia driver causes a bug in Gnome-shell when trying to use the search field in the activities menu.

Additional info:
* package version(s) : 295.20-1
* Log :
Feb 15 09:53:06 localhost kernel: [ 456.887463] gnome-shell[2530]: segfault at 10 ip 00007f969c7b4c0f sp 00007f96712ea6d8 error 6 in[7f969c7b4000+3000]

Steps to reproduce:
- Go to the "Activities" menu
- Enter something in the search field.

Note : Sorry for my english.
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 23 March 2012, 08:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  nvidia 295.33
Comment by Ionut Biru (wonder) - Wednesday, 15 February 2012, 09:15 GMT
is a know bug in nvidia 295.20. What can you do is to forward this to nvidia like all the others.
Comment by Michael Laß (Bevan) - Wednesday, 15 February 2012, 21:04 GMT
Quote from nvnews forum:

It seems to be caused by old cache files in ~/.nv/GLCache .. removing or renaming that directory fixes it.

For me this solved the problem for a moment but a bit later it reappeared.
Comment by Luca Lo Verde (enigmatichus) - Wednesday, 15 February 2012, 22:40 GMT
Same problem here, but removing/renaming ~/.nv/GLCache does not fix the problem at all.
Comment by Frederic Bezies (fredbezies) - Thursday, 16 February 2012, 13:52 GMT
Seeing this too. But the weird part is that it crashes on my desktop computer (Nvidia GT210 PCI express card), but not on my laptop (GeForce 7000M chipset).

So, laptop : geforce 7000M + nvidia 295.20 + gnome shell 3.2 = ok.
Desktop : GT210 + nvidia 295.20 + gnome shell 3.2 = crash.

Only nouveau works pretty quick on my desktop :/
Comment by Hi (raylz) - Sunday, 19 February 2012, 17:22 GMT
Affects me too, I can confirm this with my geforce gtx 275

deleteing ~/.nv didnt help
Comment by dif (dif) - Sunday, 19 February 2012, 19:17 GMT
The same thing on hp dv5 with nvidia GT96 (GeForce 9600M GT).
And writing in the search field reloads gnome with some letters, like "o", not all letters.
Architecture: i686
Comment by Jerome Poulin (ticpu) - Wednesday, 22 February 2012, 05:15 GMT
This problem affects me too, please set to confirmed:
Comment by Jerome Poulin (ticpu) - Wednesday, 22 February 2012, 05:27 GMT
Those looking to downgrade, here is the link for .tar.xz:
Comment by Anurag Panda (fosspowered) - Wednesday, 22 February 2012, 16:10 GMT
I can confirm the problem with my 8800GT. Downgrading to nvidia-290 solved the problem.
Comment by none given (hoban) - Wednesday, 22 February 2012, 17:23 GMT
I've downgraded and added the following to /etc/pacman.conf:
IgnorePkg = nvidia nvidia-utils
Please don't close this ticket until upgraded packages which fix the issue are pushed to the main repos so that those of us watching this bug will be notified that it's time to update. Thanks!
Comment by Calycé (calyce) - Sunday, 26 February 2012, 09:43 GMT
I can confirm downgrading nvidia and nvidia-utils is a working workaround.
Comment by katafractari (katafractari) - Wednesday, 29 February 2012, 12:37 GMT

work: NVIDIA GT218 [Quadro NVS 300] + latest gnome 3 WORKS
home: NVIDIA 8800GT + latest gnome 3 is CRASHING
Comment by Simon Perry (pezz) - Wednesday, 29 February 2012, 13:28 GMT
For me, this bug manifests itself when using XBMC. Whenever a video finishes playing, XBMC (or X) locks up.

The workaround was to downgrade to 290.10-3 and ignore nvidia updates.

Downgrading to 290.10-3 is no longer possible with the just released kernel 2.6.8 (unless you downgrade to the previous kernel, I guess):

[ 560.243808] nvidia: disagrees about version of symbol module_layout
[ 564.246530] nvidia: disagrees about version of symbol module_layout
[ 587.550190] nvidia: disagrees about version of symbol module_layout

Forced to use 295.20-2 which exhibits an X crash bug.

This is really broken, and regardless of an "upstream bug" this probably shouldn't be closed as it is affecting multiple facets of Arch (e.g. gnome-shell and xbmc and being unable to properly run the current kernel with this driver).
Comment by Simon Perry (pezz) - Wednesday, 29 February 2012, 13:33 GMT
Sorry, when I say "this driver" I mean the workaround version (290.10-3).
Comment by Ionut Biru (wonder) - Wednesday, 29 February 2012, 13:56 GMT
you should recompile your own that version against linux 3.2.8
Comment by Emil Ivanov (vladev) - Thursday, 01 March 2012, 07:25 GMT
There seems to be a workaround for this.

The problematic file seems to be ~/.local/share/recently-used.xbel. Deleting this file fixes the issue for a while, but later it appears again. The solution is to empty the file (echo > ~/.local/share/recently-used.xbel) and lock it with chattr (sudo chattr +i ~/.local/share/recently-used.xbel). It's probably a good idea to back it up first.

Update: 295.20-3 doesn't seem to fix the issue for me.
Comment by Jerome Poulin (ticpu) - Thursday, 01 March 2012, 16:19 GMT
Before closing this bug, can we hope that Arch downgrade the package in the repo until the bug is fixed by upstream?
Making the file immutable is a workaround for this specific bug, any threaded usage of OpenGL will trigger the bug, this is not gnome-shell specific.
Comment by Nassim K. (blueicefield) - Saturday, 03 March 2012, 14:53 GMT
I confirm that the solution provided by vladev works for me. Thanks !
Comment by katafractari (katafractari) - Saturday, 03 March 2012, 21:58 GMT
The solution works for me too. Thank you
Comment by Frederic Bezies (fredbezies) - Sunday, 04 March 2012, 08:45 GMT
Had to apply ~/.local/share/recently-used.xbel workaround.

Things are moving a little upstream.

"NVIDIA internally filed bug 941836 to track this issue."

Looks like it is related to a crash on fork call.
Comment by Geoff Carstairs (pr0cy0n) - Monday, 05 March 2012, 17:49 GMT
+1 for workaround provided by vladev, it works for me also.
Comment by Lukas Knuth (LukasKnuth) - Thursday, 08 March 2012, 19:44 GMT
Version 295.20-3 has been released, but it seams it's only compiled against Kernel 3.2.9

Meanwhile, the workaround presented by @vladev seems to work just fine.
Comment by Simon Perry (pezz) - Thursday, 08 March 2012, 21:33 GMT
Confirm 295.20-3 with 3.2.9 fixes the XBMC issue I was seeing.

Edit: Spoke too soon, subsequent testing shows I can still produce a crash by playing a movie twice (crashes on stop). I might lodge another bug regarding this as it's not strictly the same issue.
Comment by Dominik (parajew) - Sunday, 11 March 2012, 21:02 GMT

if i set locale to de_DE@euro (iso8859-15) gnome-shell crashed at startup. dmesg shows "[ 373.697042] gnome-shell[1624]: segfault at c ip b539cea3 sp b2590b8c error 6 in[b539c000+3000]"
the error occurs with 295.20-2 as well as 295.20-3. setting locale to utf8 works fine.

same bug?
Comment by Thomas Achtner (offtools) - Monday, 19 March 2012, 13:11 GMT
not sure if this is releated to this bug. but the driver seems to make problems with vbo used in some games, which could not be rendered properly.
Comment by Frederic Bezies (fredbezies) - Monday, 19 March 2012, 17:46 GMT
Don't say if it related, but with kernel 3.3, no more crashes with nvidia 295.20 ?!