Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28433 - [remmina] - vnc functionality is broken since 1.0.0-1 (and-2)

Attached to Project: Community Packages
Opened by John (graysky) - Tuesday, 14 February 2012, 22:25 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 14 April 2012, 04:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: Since this pkg was upgraded, I am unable to connect via vnc. When I launch it from the shell, I get the following error:

$ remmina
NX: detected keyboard type evdev/us
Remmina plugin NX (type=Protocol) registered.
Failed to load plugin: /usr/lib/remmina/plugins/remmina-plugin-telepathy.so.
Remmina plugin XDMCP (type=Protocol) registered.
Remmina plugin VNC (type=Protocol) registered.
Remmina plugin VNCI (type=Protocol) registered.
Remmina plugin GKEYRING (type=Secret) registered.
Remmina plugin RDP (type=Protocol) registered.
Remmina plugin RDPF (type=File) registered.
Remmina plugin RDPS (type=Preference) registered.
Remmina plugin SFTP (type=Protocol) registered.
Remmina plugin SSH (type=Protocol) registered.
remmina: symbol lookup error: /usr/lib/remmina/plugins/remmina-plugin-vnc.so: undefined symbol: gnutls_global_init

Additional info:
* package version(s) 1.0.0-2

Steps to reproduce:

1) Load remmina
2) Ctrl+N > protocol = vnc - virtual network computing
3) enter connection details and hit 'connect'

App crashes with this error:
remmina: symbol lookup error: /usr/lib/remmina/plugins/remmina-plugin-vnc.so: undefined symbol: gnutls_global_init
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 14 April 2012, 04:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  remmina-1.0.0-4
Comment by Jerome Poulin (ticpu) - Friday, 24 February 2012, 15:19 GMT
I get this error when tunnelling over SSH, using VNC directly won't connect without any error because the VNC server is IPv6 which seems unsupported.
Comment by Jerome Poulin (ticpu) - Friday, 24 February 2012, 15:44 GMT
Checking 'Disable encryption' works around the problem for me (although, still no IPv6).
This seems caused by compile warning during TLS compilation:

[ 75%] Building C object remmina-plugins/vnc/libvncserver/CMakeFiles/vncclient.dir/libvncclient/tls.c.o
/usr/src/aur/remmina/src/FreeRDP-Remmina-356c033/remmina-plugins/vnc/libvncserver/libvncclient/tls.c: In function ‘InitializeTLSSession’:
/usr/src/aur/remmina/src/FreeRDP-Remmina-356c033/remmina-plugins/vnc/libvncserver/libvncclient/tls.c:146:7: warning: ‘gnutls_kx_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:283) [-Wdeprecated-declarations]
/usr/src/aur/remmina/src/FreeRDP-Remmina-356c033/remmina-plugins/vnc/libvncserver/libvncclient/tls.c:147:7: warning: ‘gnutls_certificate_type_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:288) [-Wdeprecated-declarations]
/usr/src/aur/remmina/src/FreeRDP-Remmina-356c033/remmina-plugins/vnc/libvncserver/libvncclient/tls.c:148:7: warning: ‘gnutls_protocol_set_priority’ is deprecated (declared at /usr/include/gnutls/compat.h:285) [-Wdeprecated-declarations]
Linking C static library libvncclient.a
Comment by Sergej Pupykin (sergej) - Tuesday, 13 March 2012, 15:46 GMT
Can not reproduce - I can connect VNC with encryption successfully
Comment by Sergej Pupykin (sergej) - Tuesday, 13 March 2012, 15:47 GMT
can it be reproduced in latest remmina?
Comment by Jelle van der Waa (jelly) - Monday, 09 April 2012, 20:12 GMT
Still a bug?
Comment by John (graysky) - Monday, 09 April 2012, 21:11 GMT
Yes, now when connecting I get a window that is frozen with nothing inside it.
Comment by Jonathan De Nil (ulukai) - Tuesday, 10 April 2012, 06:14 GMT
I'm experiencing the same problem as described in the bug topic: VNC connection with encryption makes the program crash with the same error. Without encryption everything works fine.
Reinstalling both gnutls and remmina does not solve the problem.

I'm on an up to date x64 system without testing repo.
Comment by Laurent Carlier (lordheavy) - Tuesday, 10 April 2012, 16:45 GMT
Can you try packages here http://pkgbuild.com/~lcarlier/remmina/ if it fix your problems ?
Comment by John (graysky) - Tuesday, 10 April 2012, 18:59 GMT
@Lordheavy - can you post the PKGBUILD and any relevant files for these packages so I can build myself? Thanks!
Comment by Laurent Carlier (lordheavy) - Tuesday, 10 April 2012, 19:03 GMT
Here it is
   PKGBUILD (1.4 KiB)
Comment by Jonathan De Nil (ulukai) - Friday, 13 April 2012, 06:10 GMT
lordheavy, I tested your x64 package and it's working flawlessly with encryption enabled. Thank you!
Comment by John (graysky) - Friday, 13 April 2012, 19:12 GMT
@lordheavy - works for me too!

Loading...