Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28357 - [libsigc++] PKGBUILD causes makepkg to error: command not found

Attached to Project: Arch Linux
Opened by WorMzy Tykashi (WorMzy) - Saturday, 11 February 2012, 00:49 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 14 February 2012, 09:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
makepkg output:

---
$ makepkg
/home/wormzy/builds/libsigc++/PKGBUILD: line 22: package_libsigc++(): command not found

==> ERROR: An unknown error has occurred. Exiting...
---

Additional info:
Error is caused by the + signs in function names. Presumably something changed in makepkg to prevent symbols being used.


Steps to reproduce:
Download PKGBUILD and run makepkg.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 14 February 2012, 09:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk.
Comment by Giovanni Scafora (giovanni) - Saturday, 11 February 2012, 01:55 GMT
Adding a space between ++ and () solves this issue:
package_libsigc++ ()

Loading...