Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#28352 - Display the name of the packages failing the veification after download

Attached to Project: Pacman
Opened by Gero Müller (geromueller) - Friday, 10 February 2012, 18:25 GMT
Last edited by Allan McRae (Allan) - Saturday, 18 February 2012, 07:07 GMT
Task Type Bug Report
Category Output
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity High
Priority Normal
Reported Version 4.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
When a downloaded package is corrupted pacman will just tell that some packages have errors. When upgrading kde with 244 packages and 700 MB download it is extremly annoying.

Steps to Reproduce:
Download failure.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 18 February 2012, 07:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#28014 
Comment by Dave Reisner (falconindy) - Saturday, 11 February 2012, 19:43 GMT
Are you using FTP mirrors? I think you're conflating issues. pacman _does_ do this.
Comment by Allan McRae (Allan) - Saturday, 18 February 2012, 07:07 GMT
No response, so I will assume this is the same as  FS#28014 
Comment by Gero Müller (geromueller) - Monday, 20 February 2012, 19:23 GMT
Hello! Sorry for the late reply. This bug just appeared again. It is NOT a duplicate of the above one. Please check the attached console log. It is in german though :-(
Comment by Dave Reisner (falconindy) - Monday, 20 February 2012, 19:27 GMT
use "LC_ALL=C" and pacman's --debug flag if you're going to post output. Please don't involve third party tools.

This looks an awful lot like what I'm suspecting in my original reply, but we can't do anything with the output you've provided.
Comment by Gero Müller (geromueller) - Wednesday, 18 April 2012, 14:35 GMT
i found out more details. when the download fails for some reason e.g.

gphoto2-2.4.14-1-x86_64 44,7 MiB 708K/s 01:05 [#####################################################################################] 57%
Fehler: Konnte Datei 'gphoto2-2.4.14-1-x86_64.pkg.tar.xz' nicht von ftp.halifax.rwth-aachen.de übertragen : FTP response timeout
Fehler: Konnte Datei 'gphoto2-2.4.14-1-x86_64.pkg.tar.xz' nicht von ftp.halifax.rwth-aachen.de übertragen : Maximum file size exceeded

then the .part file is still around:

$ ls /var/cache/pacman/pkg/
...
gphoto2-2.4.14-1-x86_64.pkg.tar.xz.part
...

now pacman fails:
$ pacman -Su
...
(25/25) Überprüfe Paket-Integrität [#####################################################################################] 100%
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket) -> error broken package
Fehler sind aufgetreten, keine Pakete wurden aktualisiert. -> error no packages were upgarded

doing this:
$ sudo rm /var/cache/pacman/pkg/gphoto2-2.4.14-1-x86_64.pkg.tar.xz.part

fixes the problem.

.--. Pacman v4.0.3 - libalpm v7.0.3
/ _.-' .-. .-. .-. Copyright (C) 2006-2012 Pacman Development Team
\ '-. '-' '-' '-' Copyright (C) 2002-2006 Judd Vinet
'--'
Dieses Programm darf unter Bedingungen der GNU
General Public License frei weiterverbreitet werden.



Comment by Dave Reisner (falconindy) - Thursday, 19 April 2012, 10:04 GMT
I implore you: please use "LC_ALL=C" and pacman's --debug flag if you're going to post output.

Simple fix: stop using FTP servers.

Loading...