Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28287 - [mkinitpio-nfs-utils] NFS4 Support

Attached to Project: Arch Linux
Opened by Paul Gideon Dann (giddie) - Monday, 06 February 2012, 13:14 GMT
Last edited by Dave Reisner (falconindy) - Wednesday, 22 May 2013, 15:37 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Given the fact that I've been banging my head against a wall trying to get ArchLinux to net-boot with NFS4 for several days now, and that having a poke around in the code for nfsmount in myinitcpio-nfs-utils shows a suspicious lack of any mention of NFS4, I'm guessing that NFS4 is not yet supported.

I'd really like to see this feature added. Any idea how soon this might happen?
This task depends upon

Closed by  Dave Reisner (falconindy)
Wednesday, 22 May 2013, 15:37 GMT
Reason for closing:  Deferred
Additional comments about closing:  Once again: Patches can be posted to arch-projects@archlinux.org if you want this implemented.
Comment by Dave Reisner (falconindy) - Monday, 06 February 2012, 18:34 GMT
When someone writes the code for it.
Comment by Paul Gideon Dann (giddie) - Monday, 06 February 2012, 18:52 GMT
OK, so is this not being actively maintained? I may be able to write the necessary code; it's a matter of whether or not I can justify working on this in work hours.
Comment by Dave Reisner (falconindy) - Monday, 06 February 2012, 18:59 GMT
I'm active, and I'm the maintainer, but I don't plan on personally sitting down and adding this myself. I'm happy to work with you an answer any questions you might have if you're interested in putting in the effort.
Comment by Christian Neukirchen (chneukirchen) - Saturday, 10 March 2012, 16:55 GMT
I gave this a try, by including mount.nfs4 into the initramfs, and at first it seemed to work, but chown is not possible due to lack of idmapd and trying to activate idmapd during boot results in hang ups non-stop.
Comment by Mark (voidzero) - Saturday, 23 June 2012, 11:14 GMT
Any idea /why/ it hangs?
Comment by Paul Gideon Dann (giddie) - Saturday, 23 June 2012, 12:52 GMT
I think "hang ups" was intended to mean "issues, problems", not that it causes the boot to halt. I suspect other distros (Fedora, Debian) will have support for NFSv4 booting by now. I wonder if investigating their method might be helpful in determining how to deal with the need for imapd in NFSv4? Sadly, I don't think it's likely I'll have time to look at this; I've settled for NFSv3 booting for now.
Comment by Christian Neukirchen (chneukirchen) - Saturday, 23 June 2012, 13:09 GMT
IIRC, syscalls just got stuck, so the programs really hang. But unfortunately, I don't have this setup anymore and can't tell you details.
Comment by Mark (voidzero) - Saturday, 23 June 2012, 19:50 GMT
NFS4 needs rpcbind, idmapd and a mounted rpc_pipefs to /var/lib/nfs/rpc_pipefs. Has any of you tried it with all those things enabled?
Comment by Paul Gideon Dann (giddie) - Wednesday, 19 December 2012, 13:37 GMT
A patch seems to have emerged. Could you have a look and comment on its correctness? I'm wary of adopting something that looks a little too hacky...

https://wiki.archlinux.org/index.php/Network_Installation_Guide
Comment by Dave Reisner (falconindy) - Wednesday, 19 December 2012, 13:41 GMT
I sincerely doubt that the wiki page's "patch" is sufficient, but I suspect that a missing variable from the discussion here is the presence of the sunrpc module (which is needed for rpc_pipefs). calling mount(8) for an NFS mount should cause rpc_pipefs to be mounted, so there's no need for this to be done explicitly.

Ergo...

- add BINARIES="mount.nfs4"
- add MODULES="sunrpc"
- change nfsmount to mount.nfs4

The ID mapper daemon is not a requirement of nfs4.
Comment by Paul Gideon Dann (giddie) - Wednesday, 02 January 2013, 11:29 GMT
Are you waiting for someone to test this, Dave? Is that what "Waiting for Response" means?
Comment by Dave Reisner (falconindy) - Wednesday, 02 January 2013, 11:33 GMT
Yep. I have no NFS setup to test with.

Loading...