Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28285 - [libharu] Wt based app fails to link to libharu

Attached to Project: Community Packages
Opened by Miguel Revilla (migrev) - Monday, 06 February 2012, 12:38 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 23 February 2012, 08:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since libpng update to 1.5, no application developed with the Wt framework can be compiled, producing the errors:

/usr/lib/libhpdf-2.2.1.so: undefined reference to `png_image_width'
/usr/lib/libhpdf-2.2.1.so: undefined reference to `png_image_height'

Additional info:
System fully updated. Checking at upstream, seems like libharu 2.2.1 might have some issues with libpng 1.5.

Steps to reproduce:
- Create a Wt application.
- Try to compile it.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 23 February 2012, 08:00 GMT
Reason for closing:  Fixed
Comment by Miguel Revilla (migrev) - Monday, 06 February 2012, 15:44 GMT
Recompiling Wt with makepkg doesn't work either.

Manually upgrading to libharu 2.3.0rc2 and rebuilding Wt did the trick. Everything looks fine now.
Comment by Sebastian Ziebarth (voeck) - Thursday, 16 February 2012, 14:41 GMT
It seems like the applied patch is incorrect. The functions png_image_width and png_image_height are not defined anywhere, neither in libharu nor in libpng.
Comment by speps (archspeps) - Thursday, 23 February 2012, 03:02 GMT
@sergej To solve just apply an updated libpng15.patch with any occurrence of png_image_{width,height} replaced by png_get_image_{width,height}
and without the need of updating to the the latest rc.

libpng15.patch: http://paste.pocoo.org/raw/555314/ (just done with `sed -i "s/png_image/png_get_image/g" libpng15.patch"`)
Comment by Sergej Pupykin (sergej) - Thursday, 23 February 2012, 03:18 GMT
Thanks, updated. Please try libharu-2.2.1-3
Comment by Miguel Revilla (migrev) - Thursday, 23 February 2012, 07:53 GMT
Looks like 2.2.1-3 fixes it. Thanks.

Loading...