Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28243 - [zlib] makepkg missing files

Attached to Project: Arch Linux
Opened by Soup (Soup) - Friday, 03 February 2012, 23:47 GMT
Last edited by Allan McRae (Allan) - Sunday, 05 February 2012, 00:03 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: missing libz.so.1.2.6 (and symlinks libz.so.1, libz.so) from makepkg


Additional info:
* zlib 1.2.6
* attached makepkg output, resulting find and working pacman -Ql zlib


Steps to reproduce:
cdtmp
cp -a /var/abs/core/zlib .
cd zlib/
makepkg
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 05 February 2012, 00:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  user is an idiot :)
Comment by Allan McRae (Allan) - Saturday, 04 February 2012, 00:07 GMT
Something is borken with your toolchain:

Checking for shared library support...
No shared library support; try without defining CC and CFLAGS

Comment by Soup (Soup) - Saturday, 04 February 2012, 23:54 GMT
Thanks, turns out the lesson is to not mess with the default CHOST (or maybe build gcc with the new CHOST first?).

Can be marked as "user is an idiot" and closed :)

Loading...