Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28192 - [linux,udev] Broadcom brcmsmac wireless driver causes udev to hang 30 seconds during boot

Attached to Project: Arch Linux
Opened by Will Brokenbourgh (willbprog127) - Tuesday, 31 January 2012, 06:23 GMT
Last edited by Tom Gundersen (tomegun) - Tuesday, 13 March 2012, 23:29 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Broadcom brcmsmac wireless networking driver causes udev to hang boot for 30 seconds.

Additional info:
* 3.2.2-1-ARCH kernel (stock)
* udev 179-1

Steps to reproduce:
* Boot computer with Broadcom wireless card that uses the brcmsmac driver

Relevant log entries:
Sat Jan 21 16:09:09 2012: :: Waiting for UDev uevents to be processed [BUSY] udevd[173]: worker [193] timeout, kill it
Sat Jan 21 16:09:09 2012:
Sat Jan 21 16:09:09 2012: udevd[173]: seq 1096 '/devices/pci0000:00/0000:00:05.0/0000:08:00.0' killed
Sat Jan 21 16:09:09 2012:
Sat Jan 21 16:09:09 2012: udevd[173]: worker [193] terminated by signal 9 (Killed)

.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Tuesday, 13 March 2012, 23:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#27938 
Comment by Diarmuid Bourke (diarmuidbourke) - Wednesday, 01 February 2012, 15:21 GMT
The bcm4313 wireless card doesn't work, presumably as a result of this issue. rfkill list registers that the card has a hardware lock on it.
Comment by Thomas Bächler (brain0) - Wednesday, 01 February 2012, 16:43 GMT
@Diarmuid: No, this is a separate issue, please don't comment further on it in this bug report.
Comment by Thomas Bächler (brain0) - Wednesday, 01 February 2012, 16:44 GMT
This problem is known and won't be solved until the firmware loading mechanism in this driver is fixed (probably not before 3.3 is released), see [1].

[1] http://marc.info/?l=linux-netdev&m=132655490826765&w=2
Comment by Will Brokenbourgh (willbprog127) - Wednesday, 01 February 2012, 18:27 GMT
@Diarmuid: It is not the card you mentioned, lspci says it is a 'Broadcom Corporation BCM43225 802.11b/g/n (rev 01)'.

@Thomas: Thank you for that information. I felt I should submit a bug report because I did not see other bug reports with specific mention of Broadcom (mostly Realtek), so I wanted to make sure the Broadcom drivers were looked into, as well.
Comment by Åsmund Ervik (AsmundEr) - Wednesday, 01 February 2012, 22:46 GMT
I had the same problem, fixed it by adding "brcmsmac" to MODULES in rc.conf. This on a BCM4313. Don't know why it works, but it does. (I should maybe also mention that I have blacklisted the bcma module.)
Comment by Will Brokenbourgh (willbprog127) - Wednesday, 01 February 2012, 22:50 GMT
@Åsmund: Thanks for that. Already tried those things and they do not work (anymore)
Comment by Ivan Lyapunov (dront78) - Tuesday, 07 February 2012, 06:49 GMT
rc.conf MODULES doesn't work for me too
udev 180
kernel 3.2.4
BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
Comment by Tom Gundersen (tomegun) - Tuesday, 13 March 2012, 23:29 GMT
@dront78: last resort is to blacklist the module and add "modprobe <modulename>" to /etc/rc.local.

Loading...