Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28146 - [linux] [linux-lts] 3.0.x - 3.3.x Stock kernel does not boot on macbook pro 7,1

Attached to Project: Arch Linux
Opened by Cary W. (xaxaxa) - Saturday, 28 January 2012, 17:41 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 05 November 2012, 15:16 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The kernel provided in the arch repository does not boot on my macbook pro. Even the installation cd doesn't boot. The kernel gets stuck at the beginning, before even loading the initial ramdisk. The screen is blank, probably because I'm using EFI boot and the efi video device driver hasn't been loaded yet. When I compiled my custom kernel, I found that if I enable CONFIG_PREEMPT then the kernel does not boot. If i disable CONFIG_PREEMPT, any kernel works. This happens with ubuntu kernels too; when it gets stuck the last message was something like "booting node #1 ..."

Additional info:
* package version(s)
linux, linux-lts

* config and/or log files etc.
I attached the dmesg, lspci, and lsmod from when booting my custom compiled kernel.

Steps to reproduce:
Insert the installation cd into a macbook pro 7,1 and boot.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 05 November 2012, 15:16 GMT
Reason for closing:  No response
Comment by Cary W. (xaxaxa) - Saturday, 28 January 2012, 17:53 GMT
After searching around, I haven't found anyone else with the same issue. This issue would've affected a lot of people, and I'm pretty sure there would've been already a bug report. Maybe my hardware is defective?
Comment by Thomas Neumann (masmrlar) - Monday, 23 April 2012, 17:06 GMT
Hi,

I got the same (or maybe a similar) issue.
I cannot boot ArchLinux on my macbook, neither from cd, nor using an USB-stick. Tried version 20110819 and from testing version 20120412.

I tried to boot without the use of rEfit (hat a working install of Ubuntu previously on the system) and also tried to boot using rEfit (need to install OSx to get rid of that nasty boot noise).

Still trying, maybe the kernel needs some parameter got get up on that hardware...
Comment by Greg (dolby) - Monday, 15 October 2012, 09:22 GMT
Status with 3.6?

Loading...