Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28115 - [pm-utils] Outdated and non-configurable arbitrariness

Attached to Project: Arch Linux
Opened by CC (ccom) - Thursday, 26 January 2012, 15:24 GMT
Last edited by Jan de Groot (JGC) - Thursday, 12 September 2013, 12:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

This concerns the power.d feature of pm-utils.

pm-utils doesn't seem to be actively developed. At least the script /usr/lib/power.d/sched-powersave is outdated since /sys/devices/system/cpu/sched_*_power_savings do not exist anymore. The software package makes the arbitrary choice to disable power savings when on AC. Most options are not configurable, although they should be (e.g., HD Audio power savings, and it doesn't respect /etc/sysctl.conf).

Is it worthwhile to fix pm-utils in Arch Linux, or is it possible to remove it as a dependency from upower?
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 12 September 2013, 12:39 GMT
Reason for closing:  Won't fix
Additional comments about closing:  We will not fix this. pm-utils is on our list of stuff getting dropped.
Comment by Leonid Isaev (lisaev) - Friday, 25 May 2012, 22:09 GMT
The short answer to your question is "no" because:
1. Actual suspent/hibernate/etc. is not performed by upower, but rather pm-action is called.
2. pm-utils is the only tool with hook support.

Regarding the points raised in the report:
>At least the script /usr/lib/power.d/sched-powersave is outdated since /sys/devices/system/cpu/sched_*_power_savings >do not exist anymore.

pm-utils is supposed to run no a variety of *nix OS, including old linux systems. If a particular hook misbehaves, please copy it to an appropriate /etc/pm/*.d directory and modify to fit your system.

>The software package makes the arbitrary choice to disable power savings when on AC.

No, this is upowerd's fault. When it starts, it calls "pm-powersave false/true" depending on the AC being plugged/unplugged. You can either reconfigure upower to stop doing that, or blacklist all default hooks so that the above call is trivial.

>Most options are not configurable, although they should be (e.g., HD Audio power savings, and it doesn't respect >/etc/sysctl.conf).

Again, pm-utils is configured through hooks with every default one overridable via /etc/pm/* hierarchy.

IMHO this should be closed as "not a bug".
Comment by John (graysky) - Saturday, 10 August 2013, 09:45 GMT
I recently spend some time and fructration trying to understand why my /etc/sysctl.conf settings were getting overwritten[1]. In short, this package silently overwrites values that Archers add to /etc/sysctl.conf _by default_ and without warning. I am inclined to agree with CC here that this behavior is against the Arch Way and needs to be modified either by upstream or by a patch in our PKGBUILD disabling it since this package is a dep of upower which is in turn a dep to run xfce4. Users shouldn't have to opt-out of a feature that doesn't apply to their hardware >:(

1. https://bbs.archlinux.org/viewtopic.php?pid=1310171

Loading...