Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28105 - [CUPS] fails at listing printer drivers when foomatic-db-engine is installed

Attached to Project: Arch Linux
Opened by andre van schoubroeck (andremo) - Wednesday, 25 January 2012, 23:21 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 22 July 2012, 12:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

CUPS fails at listing printer drivers when foomatic-db-engine is installed

Additional info:
Packages:
foomatic-db-engine-1:4.0.7_20110707-1
cups 1.5.0-1

CUPS log file attached


Steps to reproduce:

Assuming CUPS installed.

pacman -S foomatic-db foomatic-db-engine foomatic-filters

try to install printer through CUPS web interface http://localhost:631

When the list of printers shouls appear it says "Unable to get list of printer drivers"

pacman -R foomatic-db-engine

Try to install the printer again and it will show drivers
   logfile (2.9 KiB)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 22 July 2012, 12:14 GMT
Reason for closing:  Won't fix
Additional comments about closing:  a workaround can be found now in our wiki.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 February 2012, 09:13 GMT
It seems you are alone with this issue. Can you still reproduce it?
Comment by Nicholas (nick761) - Wednesday, 18 July 2012, 23:46 GMT
  • Field changed: Percent Complete (100% → 0%)
I'm still having this issue with the latest versions of foomatic-db-engine and cups packages. It's impossible to configure any HP printer that requires hplip, since hplip depends on foomatic-db-engine.
Comment by Lionel (ioo) - Thursday, 19 July 2012, 21:28 GMT
I got the same problem. Since update my printer is not working anymore. I tried a lot of solution described from this post https://bbs.archlinux.org/viewtopic.php?id=85454
As nothing worked I find this from a blog post and my /var/log/cups/error_log is the same as attached in.

The weird thing is I can only print from HP Device Manager a page to align my cartridges. If I try to print a test page or a pdf file it fails with this message :

pending since
Thu Jul 19 23:25:29 2012
"/usr/lib/cups/backend/hp failed"

I have tried also solution provided in wiki https://wiki.archlinux.org/index.php/CUPS#HPLIP_printer_sends_.22.2Fusr.2Flib.2Fcups.2Fbackend.2Fhp_failed.22_error
Comment by Lionel (ioo) - Thursday, 19 July 2012, 23:10 GMT
I got solution on wiki. It tells you to verify device permissions are 660. It was the case for me. But a note tells you that some printers need 666 in https://wiki.archlinux.org/index.php/CUPS#Device_node_permission_troubleshooting

I tried and my printer works. So hope it helps you. I started a discussion on wiki to tell that permission have to be 660 or 666.

Loading...