Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28097 - [udev] ipw2200 fails to load

Attached to Project: Arch Linux
Opened by jr0501 (jr0501) - Wednesday, 25 January 2012, 11:19 GMT
Last edited by Tom Gundersen (tomegun) - Tuesday, 13 March 2012, 23:25 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Tom Gundersen (tomegun)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After install udev-177-3(even 178-1),i got a broken ipw2200 on my laptop (HP dv1118),but could enter into LXDE without WiFi.
Kernel: Linux 3.2.1-1-ARCH(even 3.2.1-2-ARCH)

Sat Jan 21 16:58:19 2012: :: Adjusting system time and setting kernel timezone [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Starting UDev Daemon [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Triggering UDev uevents [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Loading User-specified Modules [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Waiting for UDev uevents to be processed [BUSY] udevd[160]: worker [165] timeout, kill it
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: udevd[160]: seq 914 '/devices/pci0000:00/0000:00:1e.0/0000:02:00.0' killed
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: udevd[160]: worker [166] timeout, kill it
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: udevd[160]: seq 915 '/devices/pci0000:00/0000:00:1e.0/0000:02:06.0' killed
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: [DONE]
Sat Jan 21 16:58:19 2012: :: Bringing up loopback interface [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: udevd[160]: worker [165] terminated by signal 9 (Killed)
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: udevd[160]: worker [166] terminated by signal 9 (Killed)
Sat Jan 21 16:58:19 2012:
Sat Jan 21 16:58:19 2012: :: Checking Filesystems [BUSY] /dev/sda6: clean, 127100/625856 files, 1003041/2500107 blocks
Sat Jan 21 16:58:19 2012: /dev/sda7: clean, 68395/6512640 files, 22086591/26029308 blocks
Sat Jan 21 16:58:19 2012: [DONE]
Sat Jan 21 16:58:19 2012: :: Remounting Root [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Mounting Local Filesystems [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Activating Swap [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Configuring Time Zone [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Initializing Random Seed [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Removing Leftover Files [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Setting Hostname: arch [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Setting Consoles to UTF-8 mode [BUSY] [DONE]
Sat Jan 21 16:58:19 2012: :: Loading Keyboard Map: us [BUSY] [DONE]
Sat Jan 21 16:58:20 2012: :: Saving dmesg Log [BUSY] [DONE]
Sat Jan 21 16:58:20 2012: INIT: Entering runlevel: 5
Sat Jan 21 16:58:20 2012: :: Starting Syslog-NG [BUSY] [DONE]
Sat Jan 21 16:58:20 2012: :: Starting D-BUS system messagebus [BUSY] [DONE]
Sat Jan 21 16:58:21 2012: :: Starting NetworkManager [BUSY] [DONE]
Sat Jan 21 16:58:21 2012: :: Mounting Network Filesystems [BUSY] [DONE]
Sat Jan 21 16:58:22 2012: :: Starting Cron Daemon [BUSY] [DONE]
Sat Jan 21 16:58:22 2012: :: Starting Open Sound System [BUSY] [DONE]

Jan 21 16:58:20 arch kernel: [ 35.702071] ipw2200: Failed to send TX_POWER: Already sending a command.
Jan 21 16:58:20 arch kernel: [ 35.811396] ipw2200: Failed to send TX_POWER: Already sending a command.
Jan 21 16:58:20 arch kernel: [ 35.920617] ipw2200: Failed to send TX_POWER: Already sending a command.
Jan 21 16:58:20 arch kernel: [ 36.029808] ipw2200: Failed to send TX_POWER: Already sending a command.
Jan 21 16:58:20 arch kernel: [ 36.139014] ipw2200: Failed to send TX_POWER: Already sending a command.
Jan 21 16:58:20 arch kernel: [ 36.139115] ipw2200: Unable to initialize device after 5 attempts.
Jan 21 16:58:20 arch kernel: [ 36.143067] ipw2200: failed to register network device

Rollback system to udev-175-1 (keep kmod 4-1)temporarily solved the problem,the computer could run regularly.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Tuesday, 13 March 2012, 23:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#27938 
Comment by Stefan Förster (HotblackDesiato) - Wednesday, 25 January 2012, 20:31 GMT
This is copy of my comment to the bug report #28047 - I still have the problem. Downgrading udev to 175-1 and installation of module-init-tools (deleting kmod) resolved the issue temporarily.

-----------
I seem to have a similar problem on my wife's IBM X41. The wifi device is an "Intel(R) PRO/Wireless 2200". After install of kmod (and deletion of module-init-tools the wifi no longer works. The system needs about 4-5 minutes to boot (it has built in an SSD instead of the harddrive, so it normally boots within 3-4 seconds!). I believe that it is not only a problem with wifi, but also with startup of some other things. This happens with the Arch Linux kernel 3.2.1 as well as all of my vanilla kernels (3.0.4, 3.1.4, and 3.2.0).

dmesg:

[ 2.477950] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 2.477955] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 2.643224] ipw2200 0000:04:02.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 2.643261] ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
[ 32.966617] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.087353] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.208016] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.328537] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.449044] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.449123] ipw2200: Unable to initialize device after 5 attempts.
[ 33.450825] ipw2200: failed to register network device
[ 33.450944] ipw2200 0000:04:02.0: PCI INT A disabled
[ 33.450997] ipw2200: probe of 0000:04:02.0 failed with error -5

I have two custom udev rules files in /etc/udev/rules.d, as attached:

10-network.rules: these rules ensure that my network devices have always the same names ("eth0" and "wlan0").
51-arch.rules: for nvram

These rules (and the rest of the notebook) have always worked as expected until yesterday.
-------------
Comment by Salva Benimeli (salbefe) - Thursday, 26 January 2012, 08:32 GMT
Hello,

I have just the same problem in my laptop. After install of kmod (and deletion of module-init-tools the wifi no longer works. I've reinstalled arch and still having the same problem.

[ 2.477950] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 2.477955] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 2.643224] ipw2200 0000:04:02.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 2.643261] ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
[ 32.966617] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.087353] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.208016] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.328537] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.449044] ipw2200: Failed to send TX_POWER: Already sending a command.
[ 33.449123] ipw2200: Unable to initialize device after 5 attempts.
[ 33.450825] ipw2200: failed to register network device
[ 33.450944] ipw2200 0000:04:02.0: PCI INT A disabled
[ 33.450997] ipw2200: probe of 0000:04:02.0 failed with error -5

I don't have any custom rules.

Comment by jr0501 (jr0501) - Thursday, 26 January 2012, 11:11 GMT
@salbefe,rollback system to udev-175-1 (keep kmod 4-1) solved the problem,the computer could run regularly.
Comment by Christian Neukirchen (chneukirchen) - Thursday, 26 January 2012, 17:31 GMT
Could reproduce with X40, jr0501's downgrade fix worked, with recent kmod but old mkinitcpio-0.8/udev-175.
Comment by jr0501 (jr0501) - Friday, 27 January 2012, 10:49 GMT
With udev-179-1 and Linux 3.2.2-1,the same problem still exists.Contrarily, with udev-175-1 and Linux 3.2.2-1,the problem has disappeared.
Comment by Salva Benimeli (salbefe) - Saturday, 28 January 2012, 08:19 GMT
why this bug is still unconfirmed and unasigned?? How can I rollback to udev-175-1 ??

Thanks
Comment by Jelle van der Waa (jelly) - Saturday, 28 January 2012, 11:00 GMT
Problem is with udev, i bet if you rmmod and modprobe it again it will work. Anyway try hitting upstream (udev).
Comment by Tom Gundersen (tomegun) - Saturday, 28 January 2012, 11:43 GMT
It would be very helpful if everyone who posted logs could repost them with udev_log="debug" in /etc/udev/udev.conf. That way we'll get a bit more information.
Comment by jr0501 (jr0501) - Saturday, 28 January 2012, 14:11 GMT
@jelly,after "$sudo rmmod ipw2200" and "$sudo modprobe ipw2200",the ipw2200 ran well,WiFi could work.

Comment by jr0501 (jr0501) - Saturday, 28 January 2012, 14:58 GMT
@tomegun,logs after udev_log="debug" in /etc/udev/udev.conf. thanks
   boot (106.3 KiB)
   dmesg.log (46.7 KiB)
Comment by jr0501 (jr0501) - Saturday, 28 January 2012, 15:06 GMT
@salbefe,$sudo pacman -U mkinitcpio-0.8.0-3-any.pkg.tar.xz , $sudo pacman -U udev-175-1-i686.pkg.tar.xz
then you can rollback to udev-175-1.
Comment by Tom Gundersen (tomegun) - Sunday, 29 January 2012, 12:07 GMT
Thanks for the logs.

Could you just check if "rmmod ipw2200 ; modprobe iwlwifi" works? I'm not sure if iwlwifi should support the same hardware as ipw2200, so it would be nice to know.

Secondly, could you check if "rmmod ipw2200 ; udevadm trigger" works, or if you get the same error?
Comment by jr0501 (jr0501) - Sunday, 29 January 2012, 15:10 GMT
@tomegun, i try these commands like the following.
------------------------
$ rmmod ipw2200
libkmod: kmod_module_remove_module: could not remove 'ipw2200': Operation not permitted
Error: could not remove module ipw2200: Operation not permitted
$ sudo rmmod ipw2200
password:
$ modprobe iwlwifi
ERROR: could not insert 'mac80211': Operation not permitted
$ sudo modprobe iwlwifi
$ udevadm trigger
$ sudo udevadm trigger
$ sudo rmmod ipw2200
$ sudo modprobe iwlwifi
$ sudo rmmod ipw2200
Error: Module ipw2200 is not currently loaded
$ sudo udevadm trigger
$ sudo rmmod ipw2200
$ sudo udevadm trigger
------------------------------------
after each command,no action,no useful message,no WiFi.

then after typing "sudo rmmod ipw2200" ,"$ sudo modprobe ipw2200",WiFi is ok.
Comment by Tom Gundersen (tomegun) - Sunday, 29 January 2012, 22:28 GMT
@jr0501: thanks for reporting back. Any chance you could try one more thing?

In one terminal: "udevadm monitor"
In another: "rmmod ipw2200 ; udevadm trigger"

And post the output of the monitor (might be a lot, so a pastebin might be best).
Comment by jr0501 (jr0501) - Monday, 30 January 2012, 06:34 GMT
@tomegun,thanks.
   output (63.9 KiB)
   output (63.9 KiB)
Comment by Tom Gundersen (tomegun) - Monday, 30 January 2012, 18:49 GMT Comment by Kamil Neczaj (kneczaj) - Wednesday, 01 February 2012, 04:20 GMT
I also have a problem with ipw2200. I've installed new system and have never using any linux on that laptop before.

When the system starts udev loading takes about ~20s. After that it a message with timeout appears. I haven't the wifi card in ifconfig and cannnot use it. When I try rmmod and modprobe I get an error: "cfg80211: failed to add phy80211 symlink to netdev".
Comment by Chad Bergeron (laurion) - Friday, 03 February 2012, 21:00 GMT
Looking at the linux netdev and wireless mailing lists, this appears to be from a change in udev which is now timing out. See http://www.spinics.net/lists/linux-wireless/msg83448.html for a description of the problem. Wireless drivers will need to be updated to do asynchronous loading. rtlwifi has a patch at http://www.spinics.net/lists/linux-wireless/msg83727.html not sure about ipw2200 drivers.
Comment by Markus (kwinz) - Friday, 17 February 2012, 00:34 GMT
I have the same problem with ath:

Feb 16 13:02:16 lenovo kernel: usb 1-1.5: new high speed USB device using ehci_hcd and address 9
Feb 16 13:02:46 lenovo udevd[645]: worker [2200] timeout, kill it
Feb 16 13:02:46 lenovo udevd[645]: seq 1810 '/devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1.5' killed
Feb 16 13:02:47 lenovo kernel: usb 1-1.5: ath9k_htc: Transferred FW: ar9271.fw, size: 51312
Feb 16 13:02:47 lenovo kernel: usb 1-1.5: ath9k_htc: HTC initialized with 33 credits
Feb 16 13:02:47 lenovo kernel: ath: EEPROM regdomain: 0x809c
Feb 16 13:02:47 lenovo kernel: ath: EEPROM indicates we should expect a country code
Feb 16 13:02:47 lenovo kernel: ath: doing EEPROM country->regdmn map search
Feb 16 13:02:47 lenovo kernel: ath: country maps to regdmn code: 0x52
Feb 16 13:02:47 lenovo kernel: ath: Country alpha2 being used: CN
Feb 16 13:02:47 lenovo kernel: ath: Regpair used: 0x52
Feb 16 13:02:47 lenovo udevd[645]: worker [2200] terminated by signal 9 (Killed)
Feb 16 13:02:47 lenovo kernel: Registered led device: ath9k-phy3::radio
Feb 16 13:02:47 lenovo kernel: Registered led device: ath9k-phy3::assoc
Feb 16 13:02:47 lenovo kernel: Registered led device: ath9k-phy3::tx
Feb 16 13:02:47 lenovo kernel: Registered led device: ath9k-phy3::rx
Feb 16 13:02:47 lenovo kernel: usb 1-1.5: ath9k_htc: USB layer initialized
Comment by jose antonio (kimizombie) - Thursday, 08 March 2012, 22:17 GMT
I solved this changing /etc/rc.conf and i added the next module: ipw2200 and it solved, this happen because the kernel 3.x.x try to charge the module :)

Loading...