Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28068 - Pacman Issues

Attached to Project: Arch Linux
Opened by TuX (TuxLyn) - Monday, 23 January 2012, 16:12 GMT
Last edited by Ionut Biru (wonder) - Monday, 23 January 2012, 16:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: With upgrade to pacman v4.0.1 other stuff like yaourt and dependancy when using makepkg not working.

Steps to reproduce:
Download package bellow and try using makepkg:
http://aur.archlinux.org/packages.php?ID=55270
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 23 January 2012, 16:52 GMT
Reason for closing:  Not a bug
Additional comments about closing:  PEBCAK
Comment by Ionut Biru (wonder) - Monday, 23 January 2012, 16:19 GMT
can you be more specific about what happens?
Comment by TuX (TuxLyn) - Monday, 23 January 2012, 16:29 GMT
Yes, download package called "yaourt" from AUR for example. Extract it and try running "makepkg -s" against it. You should get this following error:

makepkg -s
==> Making package: yaourt 1.0.1-1 (Mon Jan 23 09:23:58 MST 2012)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: package-query>=1.0
==> ERROR: 'pacman' failed to install missing dependencies.

Then you can try downloading package called "fontconfig-infinality" from AUR and do the same, run "makepkg -s" against it. You will get this following error:

makepkg -s
==> Making package: fontconfig-infinality 1-1 (Mon Jan 23 09:26:12 MST 2012)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: freetype2-infinality
==> ERROR: 'pacman' failed to install missing dependencies.


So basically any package I try to install from AUR repository, no longer works after I have upgraded to new pacman version 4.0.1 I've just noticed this issue today, when I've tried using "yaourt" and when that did not work because of the "package-query>=1.0" dependancy. I've tried to install freetype2-infinality package manually from AUR, with same effect. So because pacman v4 has removed "package-query" package and some other issues with pacman that I don't know lead to error;

==> ERROR: 'pacman' failed to install missing dependencies.
Comment by Ionut Biru (wonder) - Monday, 23 January 2012, 16:34 GMT
dependencies have to be installed first and pacman doesn't support AUR.

so you first install package-query and then yaourt. same for fontconfig-infinality, first freetype2-infinality.

Loading...