Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28043 - [udev]worker timeout

Attached to Project: Arch Linux
Opened by GS (aslmaswd) - Sunday, 22 January 2012, 04:52 GMT
Last edited by Tom Gundersen (tomegun) - Sunday, 22 January 2012, 22:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
/var/log/boot
......
Sun Jan 22 12:35:12 2012: :: Waiting for UDev uevents to be processed [BUSY] udevd[227]: worker [245] timeout, kill it
Sun Jan 22 12:35:12 2012:
Sun Jan 22 12:35:12 2012: udevd[227]: seq 1237 '/devices/pci0000:00/0000:00:1c.1/0000:03:00.0' killed
Sun Jan 22 12:35:12 2012:
Sun Jan 22 12:35:12 2012: udevd[227]: worker [245] terminated by signal 9 (Killed)
Sun Jan 22 12:35:12 2012:
Sun Jan 22 12:35:12 2012: [DONE]
......
Additional info:
* udev 177-3
This task depends upon

Closed by  Tom Gundersen (tomegun)
Sunday, 22 January 2012, 22:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#27938 .
Comment by juerb (modulation) - Sunday, 22 January 2012, 11:52 GMT
Same issue on Shuttle XS35GTV2 with 3.2.1-1 x86_64 udev 177-3
Comment by Stefan Förster (HotblackDesiato) - Sunday, 22 January 2012, 15:57 GMT
The same here (IBM ThinkPad X41), udev 178-1:

/var/log/boot:
...
Sun Jan 22 16:08:30 2012: [DONE]
Sun Jan 22 16:08:30 2012: :: Waiting for UDev uevents to be processed [BUSY] udevd[165]: worker [182] timeout, kill it
Sun Jan 22 16:08:30 2012:
Sun Jan 22 16:08:30 2012: udevd[165]: seq 1009 '/devices/pci0000:00/0000:00:1e.0/0000:04:02.0' killed
Sun Jan 22 16:08:30 2012: udevd[165]: worker [182] terminated by signal 9 (Killed)
---

Please see also my post in bug #28047, as I believe it might be connected with my wifi problems after udev/kmod upgrade. Besides my new wifi problem, the machine needs several minutes to boot (instead of a few seconds before the upgrade). It especially hangs with the following boot message:

MC'97 1 converter and GPIO not read (0xff00)
Comment by Patryk Rzucidlo (PTKDev) - Sunday, 22 January 2012, 16:47 GMT
Same problem with udev 177-3 and with udev 178-1...
Waiting for UDev uevents to be processed [BUSY] udevd[235]: worker [267] timeout, kill it

http://openftp.ptkdev.it/Share/txt/dmesg-udev.txt
http://openftp.ptkdev.it/Share/txt/boot-log-udev.txt
Comment by Michal Docekal (lawmaker) - Sunday, 22 January 2012, 17:18 GMT
I can confirm this issue on HP Mini 5103, i686, with udev 177-1, 177-3 and 178-1. Downgrading to 175-1 worked. The unfortunate side effect of this bug is that it halts boot for 30 seconds before udev finally timeouts and boot sequence continues.
Comment by Florian Sittel (lettis) - Sunday, 22 January 2012, 20:58 GMT
Confirmed for Lenovo Thinkpad X121e, udev 177-3
------
Sun Jan 22 21:05:01 2012: udevd[130]: worker [143] timeout, kill it
Sun Jan 22 21:05:01 2012:
Sun Jan 22 21:05:01 2012: udevd[130]: seq 1084 '/devices/pci0000:00/0000:00:05.0/0000:01:00.0' killed
Sun Jan 22 21:05:01 2012:
Sun Jan 22 21:05:01 2012: udevd[130]: worker [143] terminated by signal 9 (Killed)
------
also, halting boot for 30 secs.

Loading...