Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28038 - [linux] After upgrade to 3.2.1 wifi device stopped working

Attached to Project: Arch Linux
Opened by c0nd0r (c0nd0r) - Saturday, 21 January 2012, 23:24 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 16 April 2012, 17:03 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
I have a realtek usb wifi adapter using with stock kernel.
After the kernel upgrade to 3.2.1-1 it stopped working and in dmesg and /var/log/messages.log the following can be seen:

Jan 21 18:37:49 localhost kernel: [ 240.996701] wpa_supplicant D 00000000fffef134 0 1167 1 0x00000000
Jan 21 18:37:49 localhost kernel: [ 240.996704] ffff8802128c5c68 0000000000000086 ffffffff00000000 dead000000100100
Jan 21 18:37:49 localhost kernel: [ 240.996708] ffff880222b2a3a0 ffff8802128c5fd8 ffff8802128c5fd8 ffff8802128c5fd8
Jan 21 18:37:49 localhost kernel: [ 240.996710] ffff8802238d7200 ffff880222b2a3a0 ffffffff8117a210 dead000000100100
Jan 21 18:37:49 localhost kernel: [ 240.996712] Call Trace:
Jan 21 18:37:49 localhost kernel: [ 240.996719] [<ffffffff8117a210>] ? __pollwait+0xf0/0xf0
Jan 21 18:37:49 localhost kernel: [ 240.996722] [<ffffffff814258bf>] schedule+0x3f/0x60
Jan 21 18:37:49 localhost kernel: [ 240.996724] [<ffffffff81426fa4>] __mutex_lock_slowpath+0x154/0x370
Jan 21 18:37:49 localhost kernel: [ 240.996727] [<ffffffff813fa360>] ? iw_handler_get_private+0x60/0x60
Jan 21 18:37:49 localhost kernel: [ 240.996729] [<ffffffff814271d6>] mutex_lock+0x16/0x30
Jan 21 18:37:49 localhost kernel: [ 240.996732] [<ffffffff81371d15>] rtnl_lock+0x15/0x20
Jan 21 18:37:49 localhost kernel: [ 240.996734] [<ffffffff813f9475>] wext_ioctl_dispatch+0x65/0x240
Jan 21 18:37:49 localhost kernel: [ 240.996736] [<ffffffff813f9770>] ? call_commit_handler+0x40/0x40
Jan 21 18:37:49 localhost kernel: [ 240.996738] [<ffffffff813f9926>] wext_handle_ioctl+0x46/0x90
Jan 21 18:37:49 localhost kernel: [ 240.996741] [<ffffffff81365870>] dev_ioctl+0xe0/0x610
Jan 21 18:37:49 localhost kernel: [ 240.996743] [<ffffffff81128c6c>] ? tlb_flush_mmu+0x6c/0x90
Jan 21 18:37:49 localhost kernel: [ 240.996745] [<ffffffff8113018d>] ? unmap_region+0x10d/0x130
Jan 21 18:37:49 localhost kernel: [ 240.996748] [<ffffffff8134a5da>] sock_ioctl+0xfa/0x2c0
Jan 21 18:37:49 localhost kernel: [ 240.996750] [<ffffffff811793af>] do_vfs_ioctl+0x8f/0x500
Jan 21 18:37:49 localhost kernel: [ 240.996752] [<ffffffff811798b1>] sys_ioctl+0x91/0xa0
Jan 21 18:37:49 localhost kernel: [ 240.996755] [<ffffffff814290c2>] system_call_fastpath+0x16/0x1b

This problem didnt exist on the previous 3.1.9 version and it's not happening either with the LTS version.

lsusb output:
Bus 002 Device 003: ID 0bda:8171 Realtek Semiconductor Corp. RTL8188SU 802.11n WLAN Adapter

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 16 April 2012, 17:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.3.2-1
Comment by Filippo cucchetto (Cuke) - Saturday, 28 January 2012, 08:59 GMT
On my Acer Aspire 5943G with Atheros AR9287 wireless card i can't connect to my Wep protected wireless network. I tried with both NetworkManager and without the issue is the same: i can successfully associate with my AP but DHCPD time out on "Broadcasting for a Lease". I tried to modprobe -r ath9k module and re-insert it but no way.
Reverting to linux 3.2.1-2 solved.
Comment by Gavin (Glinx) - Saturday, 28 January 2012, 23:34 GMT
ath9k pci wlan0 stopped.
iwconfig wouldnt associate.
I went back to linux-3.2.1-1 (x86_64) to fix
Comment by J M (bkadoctaj) - Sunday, 29 January 2012, 04:29 GMT
Problem may be with hardware encryption of wifi module:
https://bbs.archlinux.org/viewtopic.php?pid=1049159#p1049159
Comment by Gavin (Glinx) - Tuesday, 31 January 2012, 09:04 GMT
I’m starting a new bug report as reading again this bug was started for the RTL8188SU 802.11n WLAN Adapter.
I have the same problem as Cuke above with the ath9k pci card which stopped working with the linux-3.2.2 update.
@bkadoctaj Unfortunately the modprobe.conf or kernel line addition is not working for me.

New bug report at https://bugs.archlinux.org/task/28193
Comment by Olivier Pinard (Atari-San) - Sunday, 12 February 2012, 18:45 GMT
This bug affect me. All my 4 wifi card stop to work. I have Intel 5100, some realtek and ralink. Need to use another distro. Confirm the wired ethernet connection work.
Comment by Vladimir (_v_l) - Thursday, 05 April 2012, 23:39 GMT
I'm not sure if it is related but after I upgraded my notebook to kernel 3.3.1 wifi stops to work, I found several reports about that:
https://www.zarb.org/pipermail/mageia-dev/2012-April/013848.html
http://www.spinics.net/lists/linux-wireless/msg87748.html

P.S. Should I reopen the task vs. new kernel version?
Comment by Axilleas Pipinellis (markelos) - Saturday, 07 April 2012, 05:18 GMT
Same as Vladimir (_v_l). Confirmed on an atheros chipset using ath9k module. Using linux 3.3.1-1.
Comment by st.binder (nium) - Sunday, 08 April 2012, 19:30 GMT
Same here! ath9k regression on linux 3.3.1-1, no wifi connections. linux-3.2.14-1 was working.
Comment by pluto9 (pluto9) - Monday, 09 April 2012, 03:30 GMT
I have the same problem. Atheros WLAN adapter doesn't work properly on the latest kernel 3.3.1-1. When I downgraded to 3.2.14-1, it worked again.
Comment by André Queiroz (andreqls) - Monday, 09 April 2012, 16:39 GMT
I can confirm this as well on Atheros AR9285. Downgrading to 3.2.9-1 (linux and linux-headers) fixes the issue. If you can't find a suitable package in your cache, try

http://schlunix.org/archlinux/core/os/

Other official packages may be found there as well (I also had to downgrade the nvidia driver, for example, because the most recent one depends on linux>=3.3).
Comment by Filippo cucchetto (Cuke) - Monday, 09 April 2012, 19:35 GMT
Same for me as pluto9
Comment by Vladimir (vlpoliakov) - Wednesday, 11 April 2012, 02:08 GMT
Yes, I'm too..

I have internal Atheros WIFI adapter (Aspire 1830T notebook), and I have some problem.

But on USB D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT2870] all OK...

Comment by M. D. (Umino) - Sunday, 15 April 2012, 12:04 GMT
Same Problem here on my Acer Extensa 5230, but with ath5k and Kernel 3.3.1-1.

After a few hours, my wlan device disconnect and I become every second this messages on my console:

Apr 14 07:15:56 arch kernel: [34258.724577] ath5k phy0: gain calibration timeout (2412MHz)
Apr 14 07:15:56 arch kernel: [34259.058385] ath5k phy0: calibration of channel 1 failed
Apr 14 07:15:59 arch kernel: [34261.739309] ath5k phy0: gain calibration timeout (2412MHz)
Apr 14 07:16:00 arch kernel: [34262.258593] ath5k phy0: gain calibration timeout (2417MHz)
[...]

Rebooting doesn't solve the problem, I must shutdown my Notebook, than it works again.

Tried this and (for now) my WLAN works correctly:
https://bbs.archlinux.org/viewtopic.php?pid=1085620#p1085620

Hope it would fixed for ath5k modules too.
Comment by pluto9 (pluto9) - Sunday, 15 April 2012, 12:16 GMT
The new version of kernel(3.3.2) which solved this issue will come into the core repository soon. It is under the test repository at the moment.
Comment by André Queiroz (andreqls) - Monday, 16 April 2012, 16:20 GMT
linux 3.3.2-1 is now at core and seems to have fixed all problems introduced by kernel 3.3.1

Loading...