Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28030 - Boot Hang/Errors with updates to udev (version 177-3) and mkinitcpio (0.8.2-1)

Attached to Project: Arch Linux
Opened by Brandon Watkins (bwat47) - Saturday, 21 January 2012, 16:29 GMT
Last edited by Tom Gundersen (tomegun) - Tuesday, 13 March 2012, 23:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description: Since today's updates to udev and mkinitcpio my boot hangs for about 30 seconds when udev is trying to load the intel wimax driver.

Downgrading both these packages to udev 175-1 and mkinitcpio 0.8.0-3 makes boot work normally with no errors or hangs.

Here is the errors I get on boot right after the hang:
[brandon@brandon-arch ~]$ dmesg | grep 2400
[ 6.937508] i2400m_usb 1-1.1:1.0: WiMAX interface wmx0 (64:d4:da:04:85:0c) ready
[ 38.161789] i2400m_usb 1-1.1:1.0: boot-mode cmd -1: error waiting for an ack: -4
[ 38.161828] i2400m_usb 1-1.1:1.0: bootrom init failed: -4
[ 38.161850] i2400m_usb 1-1.1:1.0: i6050-fw-usb-1.5.sbcf: cannot use: -4, skipping
[ 38.161942] i2400m_usb 1-1.1:1.0: Could not find a usable firmware image
[ 38.161971] i2400m_usb 1-1.1:1.0: cannot bootstrap device: -4
[ 38.208629] i2400m_usb 1-1.1:1.0: cannot setup device: -4
[ 38.208685] i2400m_usb: probe of 1-1.1:1.0 failed with error -4
[ 38.208733] usbcore: registered new interface driver i2400m_usb


Other users have reported the same:
https://bbs.archlinux.org/viewtopic.php?id=134013

Or very similar:
https://bbs.archlinux.org/viewtopic.php?pid=1045046#p1045046
This task depends upon

Closed by  Tom Gundersen (tomegun)
Tuesday, 13 March 2012, 23:27 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#27938 
Comment by bluej774 (bluej774) - Tuesday, 07 February 2012, 08:24 GMT
  • Field changed: Percent Complete (100% → 0%)
This isn't a duplicate of  FS#27938  because that is marked as closed and fixed in testing. I'm using the latest and greatest everything in testing and this bug is still present.
Comment by Tom Gundersen (tomegun) - Tuesday, 13 March 2012, 23:27 GMT
The original bug has been reopened.

Loading...