Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#28004 - wine 1.3.37 compiled without gnutls-support

Attached to Project: Community Packages
Opened by Thomas Schuetz (Murray_B) - Thursday, 19 January 2012, 20:28 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 20 February 2012, 21:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Florian Pritz (bluewind)
Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am playing "Need for speed: World" with wine and suddenly with wine 1.3.37-1 I got the following error:
err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
and could not connect to the login-server any longer.

I rebuild the package with gnutls installed and the game worked again. I rebuild another time with "--without-gnutls" and the game stopped working again with the same error.

I think there are many online games with secure authentification, so this will not be the only game which stopped working.

Solution: Rebuild the package with gnutls installed should be enough.

Don't know if this is important, but I am using Arch 32 Bit.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 20 February 2012, 21:52 GMT
Reason for closing:  Works for me
Additional comments about closing:  Seems to be gone. We talked about this in IRC. Problem is not reproducible.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 20 January 2012, 07:09 GMT
Well then, looks like we'll need this after all. Bluewind could you handle it? I lost track of the lib32-gnutls magic.
Comment by Thomas Schuetz (Murray_B) - Saturday, 18 February 2012, 22:54 GMT
The current version 1.4rc3 seems to be compiled without gnutls again
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 19 February 2012, 00:26 GMT
Rebuild in a clean chroot by installing devtools and running extra-i686-build. This is the way we build packages. You will get the exact same package that we put in the repos that way. Next, add dependencies and try to figure out which deps wine needs to be built with to achieve success. I'd suggest starting with adding samba.
Comment by mattia (nTia89) - Monday, 20 February 2012, 10:59 GMT
how we can easily reproduce the issue ?