Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27957 - [linux] Fix for "System hangs when copying data to usb device"

Attached to Project: Arch Linux
Opened by Antonio (kokoko3k) - Monday, 16 January 2012, 07:38 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 29 February 2012, 07:28 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
In recent kernels linux may hang for seconds or minutes when transferring much data versus "slow" devices.

Additional info:
* package version(s)
linux >=2.6.36

Steps to reproduce:
Copy a big file to a slow usb stick.
Observe how the system stops to respond for a while.

However, as pointed here:
https://bbs.archlinux.org/viewtopic.php?pid=1033648#p1033648
This fixes the issue:
echo madvise > /sys/kernel/mm/transparent_hugepage/defrag
...and this is the default with ubuntu installations.

Could this be de default in next releases?
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 29 February 2012, 07:28 GMT
Reason for closing:  Fixed
Comment by Artem A Klevtsov (unikum) - Thursday, 19 January 2012, 19:26 GMT
x86_64 too.
Comment by Tobias Powalowski (tpowa) - Wednesday, 22 February 2012, 19:35 GMT
Added fix to next kernel rebuilds.
Comment by Tom Gundersen (tomegun) - Monday, 27 February 2012, 18:01 GMT
Should this not have been solved upstream by http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=a77ebd333cd810d7b680d544be88c875131c2bd3 ?

Is the intention to revert this for 3.3, or do we consider this the best option regardless of the bug in question?
Comment by Tobias Powalowski (tpowa) - Monday, 27 February 2012, 20:27 GMT
Correct for 3.3 we can remove this again.
Comment by Luke (masteryod) - Tuesday, 28 February 2012, 10:16 GMT
Sorry, Am I getting this right that this bug is solved upstream and custom hugepage setting won't be necessary for 3.3? Is this the end of slow_usb = hiccups issue?
Comment by Antonio (kokoko3k) - Tuesday, 28 February 2012, 10:19 GMT
Yes, likely
Comment by Tom Gundersen (tomegun) - Tuesday, 28 February 2012, 10:21 GMT
@Luke: it should be. See the above git link for a very detailed discussion :-)

Loading...