Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27951 - [checkgmail] requires perl-http-message and perl-http-cookies

Attached to Project: Community Packages
Opened by Bruno Guerreiro (American_Jesus) - Sunday, 15 January 2012, 18:14 GMT
Last edited by Justin Davis (juster) - Tuesday, 21 February 2012, 19:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Justin Davis (juster)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
checkgmail wont work without perl-http-message and perl-http-cookies

Additional info:
* package version: 1.13-7

# checkgmail -v
CheckGmail v1.14pre2-svn
Copyright © 2005-7 Owen Marshall

Warning: LWP::UserAgent not found ...
Warning: HTTP::Request::Common not found ...
Warning: LWP::Protocol::https not found ...

CheckGmail requires the above packages to run
Please download and install from CPAN (http://search.cpan.org) and try again ...

Steps to reproduce:
checkgmail -v
This task depends upon

Closed by  Justin Davis (juster)
Tuesday, 21 February 2012, 19:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Already depends on perl-http-cookies and perl-http-messages indirectly.
Comment by Bruno Guerreiro (American_Jesus) - Sunday, 15 January 2012, 18:17 GMT
only perl-http-cookies is needed as dependency, perl-http-cookies depends perl-http-message
Comment by Chad Shets (cvillelk) - Friday, 20 January 2012, 18:02 GMT
Thanks, perl-http-cookies should be a dependency
Comment by Justin Davis (juster) - Tuesday, 21 February 2012, 19:18 GMT
I'm not sure how you reached that conclusion but I think you are mistaken. None of the missing modules mentioned are contained in perl-http-cookies. The dependencies go like this: checkgmail -> perl-lwp-protocol-https -> perl-libwww -> perl-http-cookies -> perl-http-messages. Checkgmail already depends on perl-http-cookies and perl-http-message indirectly.

From your log it looks like you don't have perl-lwp-protocol-https installed. Installing this package installs the other requirements automatically.

Loading...