Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27885 - [hplip][PATCH] 3.11.10-2 fails to build via ABS

Attached to Project: Arch Linux
Opened by Alessio Sergi (alexwizard) - Monday, 09 January 2012, 13:41 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 10 January 2012, 03:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Building hplip 3.11.10-2 from ABS fails (see attached log).

It doesn't build due to a automake issue, so it's necessary to refresh
the autotools toolchain.
I've attached a patch that updates the PKGBUILD to fix it.

If AUTOMAKE='automake --foreign' is not set, autoreconf (automake)
complains about missing files like NEWS, README, AUTHORS, ChangeLog, etc.
and the compilation is aborted.

Additional info:
* hplip 3.11.10-2

Steps to reproduce:
* clone ABS
* copy hplip folder into working directory
* run makepkg
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 10 January 2012, 03:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in hplip-3.11.12-1 in [testing]

Loading...