Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27850 - Phonon Backend Plugin could not be loaded

Attached to Project: Arch Linux
Opened by Ernest Grothauzen (Lone_Wolf) - Friday, 06 January 2012, 15:39 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 08 February 2012, 14:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrade to phonon 1:4.6.0-1 pure QT applications no longer can use sound .

Logs show this :
Warning::bool Phonon::FactoryPrivate::CreateBackend Phonon Backend Plugin could not be loaded

This happens both with phonon-vlc and phonon-gstreamer backends.

Phonon 1:4.5.1-2 does not have this problem.

in 1:4.6.0-1 this line was added to the pkgbuild :

+ -DPHONON_QT_PLUGIN_INSTALL_DIR=/usr/lib/qt/plugins/designer

Both phonon-vlc and phonon-gstreamer install to usr/lib/kde4/plugins/phonon_backend/
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 08 February 2012, 14:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  phonon 1:4.6.0-2
Comment by Andrea Scarpino (BaSh) - Friday, 06 January 2012, 16:11 GMT
We do not set any path for the plugins, neither kdelibs is installed when we build the phonon backends; so that path is set by upstream. This means your request should go to upstream.

However you could set the QT_PLUGIN_PATH this way:
export QT_PLUGIN_PATH=$HOME/.kde4/lib/kde4/plugins/:/usr/lib/kde4/plugins/
Comment by Bjørnar Hansen (anachron) - Saturday, 14 January 2012, 15:14 GMT
This is a duplicate of  FS#11070 .
You can fix the problem by linking the (kde-)phonon backend plugin directory to the (qt-)phonon plugin directory:
# ln -s /usr/lib/kde4/plugins/phonon_backend/ /usr/lib/qt/plugins/

Qt looks for plugins in /usr/lib/qt/plugins/, but as we use phonon (and backend plugins) provided by KDE, they are located in usr/lib/kde4/plugins/.
Comment by Andrea Scarpino (BaSh) - Saturday, 14 January 2012, 15:25 GMT
There is no need of symlink anything. Just export QT_PLUGIN_PATH
Comment by solsTiCe (zebul666) - Sunday, 05 February 2012, 12:46 GMT
  • Field changed: Percent Complete (100% → 0%)
I don't understand how export QT_PLUGIN_PATH could be a solution ? how do you expect user to know that ? except by looking for the bug on the net and find that bug report ?
why not a symlink in the package to fix that ?
or create a profile file in /etc/profile.d to export the variable.
Comment by Andrea Scarpino (BaSh) - Wednesday, 08 February 2012, 13:04 GMT Comment by Kacper Żuk (Kazuldur) - Wednesday, 08 February 2012, 14:41 GMT
It works now on x86_64 with Andrea's package.

Loading...