Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27846 - kmod 3.3 busted my xorg start.

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 06 January 2012, 09:41 GMT
Last edited by Tom Gundersen (tomegun) - Friday, 06 January 2012, 11:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Simple to reproduce. Simply have a system using nvidia driver, and reboot after applying kmod installation.

Even if I renamed blacklist.conf.pacsave as blacklist.conf, it is not taken into account.

Tried without luck "udevadm trigger".

Every single time I try to launch startx or gdm, I got this :

NVIDIA : could not open the device file /dev/nvidiactl (no such device or address).


Additional info:
kmod 3.3

Steps to reproduce:

See details
This task depends upon

Closed by  Tom Gundersen (tomegun)
Friday, 06 January 2012, 11:54 GMT
Reason for closing:  Fixed
Comment by Frederic Bezies (fredbezies) - Friday, 06 January 2012, 09:47 GMT
Downgrading to modules-init-tools make my system work again !
Comment by Andreas Radke (AndyRTR) - Friday, 06 January 2012, 10:08 GMT
Same to me. Blacklisting nouveau is not recognised. Neither in its previous location nor added to /etc/modprobe.d/modprobe.conf nor /etc/depmod.d/depmod.conf.
Comment by lorim (lorim) - Friday, 06 January 2012, 10:10 GMT
it seems like all the /etc/{modprobe,depmod}.d/*.conf files are ignored
Comment by Thomas B├Ąchler (brain0) - Friday, 06 January 2012, 10:11 GMT
This could be related to our weird symlinking magic in /lib/modules/ that we use since Linux 3.1. Maybe kmod does not follow symlinks like m-i-t did.
Comment by Andreas Radke (AndyRTR) - Friday, 06 January 2012, 10:17 GMT
putting my blacklisting *.conf files into /lib/modules.d/ seems to be the only working place right now. seems to be a bug in kmod not recognising files in /etc/{depmod,modprobe}.d/
Comment by Dave Reisner (falconindy) - Friday, 06 January 2012, 10:57 GMT
Please retest with kmod-3-4 when it hits testing in the next hour.
Comment by Andreas Radke (AndyRTR) - Friday, 06 January 2012, 11:23 GMT
fixed. thanks.

Loading...