Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#27844 - linux-3.2-1 missing Broadcom wireless drivers

Attached to Project: Arch Linux
Opened by Zeqadious (Zeqadious) - Thursday, 05 January 2012, 21:52 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 12 January 2012, 15:09 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No



The latest testing linux kernel (3.2-1) is missing the wireless drivers found previously in brcmsmac and brcmfmac modules.

as per commit 5b435de0d786869c95d1962121af0d7df2542009 the drivers have been moved and the config needs tweakage to get them back:;a=commit;h=5b435de0d786869c95d1962121af0d7df2542009

"Add the brcm80211 tree to drivers/net/wireless, and disable the version that's
in drivers/staging. This version includes the sources currently in staging,
plus any changes that have been sent out for review.

Sources in staging will be deleted in a followup patch."
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 12 January 2012, 15:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  added changes to trunk, next rebuild will fix it.
Comment by Thomas (radioactiveman) - Thursday, 05 January 2012, 22:37 GMT Comment by Thomas Weißschuh (t-8ch) - Friday, 06 January 2012, 00:23 GMT
Pointless comment, sorry for the noise
Comment by Göran Gustafsson (twiggy) - Saturday, 07 January 2012, 12:29 GMT
A fix would be really appreciated. I'm stuck with no WiFi and can't downgrade because i need fixes for i915.
Comment by Sagar Chalise (sagarchalise) - Saturday, 07 January 2012, 12:42 GMT
I am back to wl driver until this is resolved. I heard the broadcom opensource driver has been moved from staging to net subsytem.;a=tree;f=drivers/net/wireless/brcm80211;h=4dda758f2a794063f81f5b118bd15bd98c46078f;hb=HEAD
Comment by Olivier (litemotiv) - Sunday, 08 January 2012, 12:23 GMT
3.2-2 seems to reintroduce brcmfmac (sdio) but not brcmsmac (pci) module
Comment by Pierre Schmitz (Pierre) - Sunday, 08 January 2012, 12:31 GMT
I can confirm that my wireless still does not work: BCM4313
Comment by Thomas Bächler (brain0) - Sunday, 08 January 2012, 22:10 GMT
I am unsure if it is better to disable BCMA (the b43 driver uses it for some devices) so we can enable BRCMSMAC, or leave BCMA enabled and thus BRCMSMAC disabled. The whole situation is confusing.

I am told that this conflict will be fixed in 3.3 - but that doesn't help us right now.
Comment by Olivier (litemotiv) - Sunday, 08 January 2012, 22:27 GMT
Thomas, if it helps: it's probably easier for people relying on bcma to stick with the old kernel for a while. There is a number of laptops that can't run linux without patches that have landed in 3.2, including some of the newer Macbooks. So incorporating brcmsmac now would make sure that at least everybody can run Arch until 3.3 is here, or until a better fix for running both bcma and brcmsmac is found.
Comment by Pierre Schmitz (Pierre) - Sunday, 08 January 2012, 22:48 GMT
Well, it wouldn't be great for both user groups to keep the 3.1 kernel till this is fixed in 3.3 or later.

I am wondering if this is a real build time conflict or if it is jst about the fact that both drivers claim to support the same hardware? The latter should be solvable b some blacklisting by the user. Actually that wouldn't be the first conflict of that kind; there are similar problems with some ata or ethernet drivers.
Comment by Thomas Bächler (brain0) - Sunday, 08 January 2012, 23:20 GMT
Kbuild prevents enabling both at the same time, even as modules.
Comment by Andres Kanski (akanski) - Sunday, 08 January 2012, 23:46 GMT
As far as I know, the brcmsmac module does not compile along with bcma enabled at once, given that the Broadcom IEEE802.11n PCIe SoftMAC WLAN driver is currently unable to use the bcma code.

Despite that, I have tried to force the compiling of the brcmsmac module. And the result of my attempt, ignoring all errors to find out about this issue, makes us clear what is wrong with bcma enabled (see, linux-3.2-brcmsmac-errors.txt).

Well, these are the steps in order to reproduce,

* Download BRCM80211 driver (;a=snapshot;h=e0444488da24423164f30c5f60aa9aec5ee594e3;sf=tgz).
* Decompress it (and verify linux-headers installation).
* Apply the compiling patch into brcmsmac subdirectory (brcmsmac-compiling.patch).
* Try to compile brcmsmac as any program written in C.

All this stuff points to one inevitable conclusion, this is a matter for kernel hackers and developers which will possibly be solved in the next version (3.3); so an alternative compiling is needed to deal with that problem, unless someone finds a patch to fix it on Linux 3.2.
Comment by Olivier (litemotiv) - Sunday, 08 January 2012, 23:57 GMT
Do we know which cards currently require bcma and can't run on b43 or brcmsmac alone? I couldn't find reliable information on that, but what i did find is that bcma enables b43 support for certain cards that are also supported by brcmsmac. So if that is the case, disabling bcma wouldn't leave anyone behind.

Also Roland Vossen, one of the primary Broadcom wireless devs, also visits the Arch forums occasionally. We could send him an email (rvossen [at] broadcom [dot] com) if everything else fails.
Comment by Olivier (litemotiv) - Monday, 09 January 2012, 11:31 GMT
FYI: i have emailed Roland Vossen for clarification, will report back here if / when he replies.
Comment by LoopBack (LoopBack) - Wednesday, 11 January 2012, 15:18 GMT
I may be wrong, but i think we need this patch:
I played around with it and got it compiling, but it seems like i messed something up, as I get "Error: could not insert module brcmsmac.ko: Unknown symbol in module"...
Comment by Pierre Schmitz (Pierre) - Wednesday, 11 January 2012, 15:47 GMT
The compat-wireless module can be used in the meantime. Unfortunately kmod (currently in testing) is broken.
Comment by Thomas Bächler (brain0) - Wednesday, 11 January 2012, 16:46 GMT
The next build will disable BCMA and enable brcmsmac instead. We will definitely not backport the 3.3 work to make them happy together.