Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#27835 - XEN broken with glibc 2.15

Attached to Project: Arch Linux
Opened by Michael Werner (Xaseron) - Thursday, 05 January 2012, 12:17 GMT
Last edited by Allan McRae (Allan) - Thursday, 05 January 2012, 13:48 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


After i updated to glibc 2.15 i got strange errors in dom0. Then tried to reboot but everytime i try to boot a kernel in dom0 i get a kernel panic or a drop into ramfs.
Downgrading to 2.14 worked and everything works again.

Accordingly to
I tried to compile the package with:
CFLAGS="-march=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -mno-tls-direct-seg-refs"
But its breaks:
gcc ../sysdeps/ieee754/dbl-64/s_log1p.c -c -std=gnu99 -fgnu89-inline --param=ssp-buffer-size=4 -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -march=native -mno-tls-direct-seg-refs -pipe -Wstrict-prototypes -Wno-uninitialized -D__NO_MATH_INLINES -D__LIBC_INTERNAL_MATH_INLINES -I../include -I/var/abs/core/glibc/src/glibc-build/math -I/var/abs/core/glibc/src/glibc-build -I../sysdeps/x86_64/elf -I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/x86_64/fpu/multiarch -I../sysdeps/x86_64/fpu -I../sysdeps/x86_64/multiarch -I../nptl/sysdeps/x86_64 -I../sysdeps/x86_64 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64/wordsize-64 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.2/include -isystem /usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h -DNOT_IN_libc=1 -DIS_IN_libm=1 -o /var/abs/core/glibc/src/glibc-build/math/s_log1p.o -MD -MP -MF /var/abs/core/glibc/src/glibc-build/math/s_log1p.o.dt -MT /var/abs/core/glibc/src/glibc-build/math/s_log1p.o
../sysdeps/ieee754/dbl-64/wordsize-64/s_floor.c:50:1: error: expected identifier or ‘(’ before ‘{’ token
make[2]: *** [/var/abs/core/glibc/src/glibc-build/math/s_floor.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/abs/core/glibc/src/glibc/math'
make[1]: *** [math/others] Error 2
make[1]: Leaving directory `/var/abs/core/glibc/src/glibc'
make: *** [all] Error 2

This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 05 January 2012, 13:48 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#27828  and  FS#27823