Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27832 - openssl 1.0.0.f-1 was linked to glibc 2.15

Attached to Project: Arch Linux
Opened by Si Feng (danielfeng) - Thursday, 05 January 2012, 06:32 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 13 January 2012, 12:43 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

It was linked to glibc 2.15, however glibc update itself may cause kernel panic so some people can only stay with glibc 2.14 right now. If they upgrade openssl on a glibc 2.14 system, it won't work.

Error message:
openssl: /lib/libc.so.6: version `GLIBC_2.15' not found (required by openssl)


glibc 2.15-3 issue:
https://bugs.archlinux.org/task/27828
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 13 January 2012, 12:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  We support only up-to-date systems
Comment by Pierre Schmitz (Pierre) - Thursday, 05 January 2012, 14:52 GMT
Selective updates are not supported in Arch. Either update everything or you are on your own. This is also not an openssl bug.
Comment by Si Feng (danielfeng) - Thursday, 05 January 2012, 17:00 GMT
Right, but if the new version does require glibc 2.15, how about adding glibc>=2.15? I've upgraded other packages, openssl is the only one that doesn't like glibc 2.14.

glibc is the most common trouble maker so not only a few people put it in ignore package list. It's not entirely "selective updates" but it is not supposed to be a bad idea, otherwise pacman should not have supported this feature, right?
Comment by Si Feng (danielfeng) - Thursday, 05 January 2012, 17:56 GMT
Rebuilding from abs on glibc 2.14 system worked.
Comment by Ionut Biru (wonder) - Thursday, 05 January 2012, 18:00 GMT
don't update if is broken

Loading...