Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27826 - [devtools] building in clean chroot fails on multiple machines

Attached to Project: Arch Linux
Opened by John (graysky) - Wednesday, 04 January 2012, 19:27 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 04 January 2012, 19:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am following the "Building_in_a_Clean_Chroot" wiki article page but am getting errors I can't rationalize. I can confirm this error on my workstation (x86_64 with [testing] enabled) and on an older fileserver (i686). Flagged as critical since key functionality is seemingly missing confirmed on two machines.

$ mkdir /media/data/archbuild
$ CHROOT=/media/data/archbuild/root

$ sudo mkarchroot $CHROOT base base-devel sudo
<< install completes successfully >>

$ cp /var/abs/core/glibc ./ && cd glibc

$ sudo makechrootpkg -c -r $CHROOT
==> Creating clean working copy...done
grep: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
/usr/sbin/makechrootpkg: line 330: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
grep: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
/usr/sbin/makechrootpkg: line 335: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
sed: can't read /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
/usr/sbin/makechrootpkg: line 340: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
sed: can't read /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
/usr/sbin/makechrootpkg: line 345: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
grep: /media/data/archbuild/root/facade/etc/makepkg.conf: No such file or directory
/usr/sbin/makechrootpkg: line 378: /media/data/archbuild/root/facade/etc/sudoers.d/nobody-pacman: No such file or directory
chmod: cannot access `/media/data/archbuild/root/facade/etc/sudoers.d/nobody-pacman': No such file or directory
/usr/sbin/makechrootpkg: line 385: /media/data/archbuild/root/facade/etc/locale.conf: No such file or directory
==> ERROR: '/media/data/archbuild/root/facade' does not appear to be a Arch chroot.
==> ERROR: Build failed, check /media/data/archbuild/root/facade/build

Additional info:
* package version(s) 20111220-1
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 04 January 2012, 19:35 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Wednesday, 04 January 2012, 19:34 GMT
the CHROOT variable is wrong when using in makechrootpkg. it should be /media/data/archbuild

Loading...