Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27819 - [gambas3-ide] can't start: "gbr3: no project file in '/usr/bin/gambas3'"

Attached to Project: Community Packages
Opened by João Rodrigues (gothicknight) - Wednesday, 04 January 2012, 11:50 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 07 January 2012, 19:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Gambas3 IDE doesn't start with the following error: "gbr3: no project file in '/usr/bin/gambas3'."

Additional info:
* package version(s)
> gambas3-ide 3.0.0-1

Steps to reproduce:

Just run the Gambas IDE from the desktop icon or by running gambas3 from command line.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 07 January 2012, 19:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  gambas3-3.0.0-2
Comment by Alexander F Rødseth (xyproto) (trontonic) - Wednesday, 04 January 2012, 14:42 GMT
Confirmed. I'm also able to reproduce this.

~% gambas3
gbr3: no project file in '/usr/bin/gambas3'.
1~%

gambas3-ide 3.0.0-1
x86_64
Comment by Antonio (kokoko3k) - Thursday, 05 January 2012, 12:13 GMT
Happens on 32bit too, i'm waiting for an answer from benoit minisini to understand if it is a packaging issue.
Comment by Antonio (kokoko3k) - Friday, 06 January 2012, 17:31 GMT
Actually it seems to be a packaging issue.
On mandriva 3.0 ide works:
http://xt7-player.sourceforge.net/xt7forum/viewtopic.php?f=7&t=149&st=0&sk=t&sd=a&start=10
Comment by Pavel Čermák (pajacer) - Saturday, 07 January 2012, 16:28 GMT
In the /usr/lib/gambas3 missing two files (gb.eval.highlight.component and gb.eval.highlight.gambas). Copy them there a everything will be OK.
Comment by Antonio (kokoko3k) - Saturday, 07 January 2012, 16:34 GMT
Are you talking to the package mantainer?
...cause i've no idea where to get them from.
Comment by Pavel Čermák (pajacer) - Saturday, 07 January 2012, 16:39 GMT
No. Package gambas3-gb-eval-highlight-3.0.0-1-x86_64.pkg.tar.xz is empty.
Comment by Pavel Čermák (pajacer) - Saturday, 07 January 2012, 16:42 GMT
Missing files I compiled from source code.
Comment by Laurent Carlier (lordheavy) - Saturday, 07 January 2012, 19:12 GMT
Ok, found the problem, thanks pajacer, fixed packages should follow soon

Loading...