Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#27818 - PCM signed big-endian encoding as unsigned

Attached to Project: Arch Linux
Opened by Gavin (Glinx) - Wednesday, 04 January 2012, 10:56 GMT
Last edited by Ionut Biru (wonder) - Friday, 27 January 2012, 17:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



PCM signed big-endian requied, but all attempts encoded as unsigned.

package version ffmpeg 20111211-1

After some recent home video recodes I noticed that my usual signed pcm sound codec (pcm_s16be) has encoded as unsigned. After trying a few other pcm signed codecs they also came out as unsigned

Steps to reproduce:

ffmpeg -i in.MTS -vcodec dnxhd -threads 4 -b:v 240M -pix_fmt yuv422p -acodec pcm_s16be

No errors were given, output said it was singed. When checked in video editor and Mediainfo it was in fact unsigned.
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 27 January 2012, 17:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  ffmpeg 20120127-1
Comment by Gavin (Glinx) - Wednesday, 04 January 2012, 11:02 GMT
Downgrading FFmpeg to version ffmpeg-20111123-1 solved the problem.
Comment by Ionut Biru (wonder) - Wednesday, 04 January 2012, 17:00 GMT
if the old snapshot works and new one doesn't it means that there is a regression.

what can we do is to try a new snapshot[1] and see if is fixed and if not, report upstream.

Comment by Gavin (Glinx) - Wednesday, 04 January 2012, 17:43 GMT
Thank you.
Unfortunately it doesn’t, I'll report upstream.
Comment by Gavin (Glinx) - Thursday, 05 January 2012, 19:30 GMT
Reported to ffmpeg Ticket #873
Comment by Gavin (Glinx) - Friday, 27 January 2012, 17:20 GMT
FFmpeg have removed the patch that caused the regression (since 8e8c51318c1fe4ae61de578f0823b88aa3fe8222). The Arch Linux package ffmpeg 20120127-1 released today confirms all is well again. Thank you Ionut Biru and FFmpeg.