AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#27800 - "Only lowercase letters are allowed" with lowercase-only PKGBUILD name

Attached to Project: AUR web interface
Opened by henning mueller (phects) - Monday, 02 January 2012, 11:49 GMT
Last edited by Allan McRae (Allan) - Monday, 02 January 2012, 19:45 GMT
Task Type Support Request
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 1.9.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I keep on getting the following message from AUR when uploading the attached PKGBUILD:

"Invalid name: only lowercase letters are allowed."

For me the cause of this message is not traceable, as every relevant filename or variable content in the PKGBUILD seem fairly lowercase to me.


$ tar tf linux-pax-3.1.5-1.src.tar.gz

linux-pax/
linux-pax/PKGBUILD
linux-pax/change-default-console-loglevel.patch
linux-pax/i915-fix-ghost-tv-output.patch
linux-pax/i915-fix-incorrect-error-message.patch
linux-pax/usb-add-reset-resume-quirk-for-several-webcams.patch
linux-pax/config
linux-pax/config.x86_64
linux-pax/linux-pax.install
linux-pax/linux-pax.preset


The PKGBUILD's variable "header":

pkgbase='linux-pax'
pkgname=('linux-pax' 'linux-pax-headers')
_kernelname="${pkgname#linux}"
_basekernel='3.1'
_paxver='test20'
pkgver="${_basekernel}.5"
pkgrel='1'
arch=('i686' 'x86_64')
url='http://www.kernel.org/'
license=('GPL2')
depends=('paxctl')
options=('!strip')
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 02 January 2012, 19:45 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#16394 
Comment by henning mueller (phects) - Monday, 02 January 2012, 12:53 GMT
The attached PKGBUILD source archive was generated with "makepkg --source". A manual "tar cf .." did not work, either.
Comment by Jakob Matthes (jakobm) - Monday, 02 January 2012, 13:41 GMT
You are trying to submit a split-package, see  FS#16394 .
Current AUR can't detect that and returns a confusing error message.
Comment by henning mueller (phects) - Monday, 02 January 2012, 14:37 GMT
That's depressing. Thanks for your help.

Loading...