Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27795 - [linux] Deauthenticating from the wireless router by local choice (reason=3)

Attached to Project: Arch Linux
Opened by Halim Can Albasan (sultanhalim) - Sunday, 01 January 2012, 23:07 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 02 May 2012, 07:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Hi all,

Before adding this task, there was a long procedure for me. Let me first tell you that I had no wireless problems before, and I am not a really frequent upgrader. It all started when I renewed my router from Airties RT-206 to INCA IM-300NX. My connection with the router was frequently dropping. When I did some research, I saw it was a pretty common issue, the error in the summary.. And I saw that it most probably happens due to the wrong wpa_supplicant configuration, the selection of the wrong authentication method (wpa/wpa2, etc.). Eventhough my older router was set up for authenticating with wpa2, my wpa_supplicant.conf was configured for wpa and it was working for years (I didn't even know that there was a seperate configuration for wpa2). Then I changed the configuration to wpa2; the error above was gone but some loop of messages was still coming such as:

[187683.184759] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[187683.279913] wlan0: authenticated
[187683.280028] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[187683.288219] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[187683.288224] wlan0: associated
[187745.178099] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[187745.258749] wlan0: authenticated
[187745.258834] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[187745.267038] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[187745.267042] wlan0: associated
[187920.144739] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[187920.211087] wlan0: authenticated
[187920.211162] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[187920.220403] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[187920.220406] wlan0: associated
[187991.171431] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[187991.238183] wlan0: authenticated
[187991.238297] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[187991.246478] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[187991.246482] wlan0: associated
[188002.954834] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[188003.040095] wlan0: authenticated
[188003.040211] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[188003.048414] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[188003.048419] wlan0: associated

Disabling N-type connection in the router settings helped for a short amount of time, but this wasn't a permanent solution. Then I realised my new router has this WPS feature which enhances the security and needs a special wpa_supplicant configuration. So I disabled this WPS feature of the router and everything started to work perfectly!! But then I left the computer on for 2 days for some downloads and left home. When I come back today, the problem was there again.


[176869.527976] wlan0: associated
[177107.952493] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177108.034459] wlan0: authenticated
[177108.034569] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177108.042744] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177108.042748] wlan0: associated
[177127.878213] wlan0: deauthenticating from f4:3e:61:34:f0:44 by local choice (reason=3)
[177131.595846] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177131.645752] wlan0: authenticated
[177131.645831] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177131.655691] wlan0: RX AssocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177131.655696] wlan0: associated
[177133.308808] wlan0: deauthenticating from f4:3e:61:34:f0:44 by local choice (reason=3)
[177137.682498] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177137.732235] wlan0: authenticated
[177137.732375] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177137.745441] wlan0: RX AssocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177137.745446] wlan0: associated
[177190.765514] wlan0: deauthenticating from f4:3e:61:34:f0:44 by local choice (reason=3)
[177194.359170] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177194.438936] wlan0: authenticated
[177194.439065] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177194.447435] wlan0: RX AssocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177194.447439] wlan0: associated
[177196.062693] wlan0: deauthenticating from f4:3e:61:34:f0:44 by local choice (reason=3)
[177200.435830] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177200.517336] wlan0: authenticated
[177200.517515] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177200.525612] wlan0: RX AssocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177200.525616] wlan0: associated
[177236.162472] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177236.246740] wlan0: authenticated
[177236.246842] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177236.256047] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177236.256050] wlan0: associated
[177374.162453] wlan0: direct probe to f4:3e:61:34:f0:44 (try 1/3)
[177374.212301] wlan0: direct probe responded
[177374.252289] wlan0: authenticate with f4:3e:61:34:f0:44 (try 1)
[177374.254767] wlan0: authenticated
[177374.254881] wlan0: associate with f4:3e:61:34:f0:44 (try 1)
[177374.264849] wlan0: RX ReassocResp from f4:3e:61:34:f0:44 (capab=0x411 status=0 aid=1)
[177374.264852] wlan0: associated

It disappears after several iterations. At first I suspected if my router was still trying WPS authentication, but couldn't find any clue to it. So I am stuck now and need your help. The dmesg output regarding wlan0 is above.

Additional info:
# uname -a
Linux sultanhalim 3.1.5-1-ARCH #1 SMP PREEMPT Sun Dec 11 06:26:14 UTC 2011 i686 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel GNU/Linux

core/wpa_supplicant 0.7.3-4 (base) [installed: 0.7.3-3]
core/netcfg 2.6.8-1 [installed]

# cat /etc/wpa_supplicant.conf
ctrl_interface=/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1
network={
ssid="INCA"
scan_ssid=1
proto=WPA2
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
psk=some_hex_key_which_is_correct
}

# cat /etc/network.d/home
CONNECTION='wireless'
INTERFACE='wlan0'
SCAN='yes'
#SECURITY="wpa"
ESSID='INCA'
SECURITY='wpa-config'
WPA_CONF='/etc/wpa_supplicant.conf'
#IP='dhcp'
IP='static'
IFOPTS='192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.0'
GATEWAY='192.168.1.1'

WPAOPTS='-Dwext'

***using the driver ath5k with 05:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

Just ask for anything else please. Thanks in advance..
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 02 May 2012, 07:00 GMT
Reason for closing:  Fixed
Comment by Vijay (drekthar) - Tuesday, 10 January 2012, 11:37 GMT
omg i have the same problem.......... registered in this site beacause of this.....

i running openwrt on a x86 system with a atheros ar5212 minipci card in client mode ......

i constantly get the same error as you do

wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=2)
wlan0: associated

hope we can get a solution for this....
ps: trying madwifi gives me a hal status 3 error
Comment by Amadeusz Starzykiewicz (megawebmaster) - Wednesday, 18 January 2012, 22:51 GMT
Hmmm, that's weird because I'm using b43 driver and I've got the same problem, although when I'm connecting to my older router - it works flawlessly. Both are WPA2, on the newer one I've disabled WPS as @sultanhalim said, but it didn't help me at all. Currently I have to be connected via wire, but it is really inconvenient. I'm using testing repositories, but linux-firmware is from core, b43-firmware is from AUR (the same that worked before without problems) and, of course, linux 3.2.1-1.

EDIT: I've searched through web and found some clues including disabling N mode in WiFi, but I can't find which options I should set for b43. And I've forgotten about telling you my hardware: 14e4:432b which means Broadcom 4322 chip in Dell 1555 Studio notebook.
Comment by Mihai Coman (z0id) - Tuesday, 07 February 2012, 15:45 GMT
Are you using IPv6/Networkmanager? There was a problem with with connection being closed when default dns server expired, if MaxRtrInterval was too low in radvd on the router.
Comment by Amadeusz Starzykiewicz (megawebmaster) - Tuesday, 07 February 2012, 16:01 GMT
Nope, my router is IPv4, but I'm using NetworkManager. I've tried Wicd too, but it didn't help.
Comment by Vijay (drekthar) - Thursday, 09 February 2012, 10:59 GMT
it happens with kernel 3.0 also i dont think it is a driver issue maybe something else....
Comment by Tobias Powalowski (tpowa) - Saturday, 28 April 2012, 08:01 GMT
Status on 3.3 series?
Comment by Amadeusz Starzykiewicz (megawebmaster) - Tuesday, 01 May 2012, 08:41 GMT
As far as I can see - it is better now. There was a regression on 3.3 but after 3.3.1 it is good enough. Sometimes I can see the same thing, but I cannot trace its source. For me - you can close this bug.
Comment by Halim Can Albasan (sultanhalim) - Tuesday, 01 May 2012, 19:49 GMT
I am almost pretty sure now that this is router related. Maybe the drivers and the manufacturers lost compatibility in some modern versions; even maybe the WPS protocol might be the issue, since it's somehow a new technique, some manufacturers' implementation may not have completed their standardization. But I've had enough time to try this thing, turns out the problem is in my router itself. Although it may not be the case with other instances, I agree that this bug might be closed now..

Loading...