Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#27755 - [gnome-menus] gmenu-simple-editor is not working properly

Attached to Project: Arch Linux
Opened by Daniel Apolinario (dapolinario) - Wednesday, 28 December 2011, 23:00 GMT
Last edited by Allan McRae (Allan) - Saturday, 17 November 2012, 02:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: When I click on a box, the following error appears on the terminal.

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/GMenuSimpleEditor/", line 147, in __on_hide_toggled
self.menu_file_writer.queue_sync (child_iter)
File "/usr/lib/python2.7/site-packages/GMenuSimpleEditor/", line 186, in queue_sync
menu_file_iter = find_menu_file_parent (self.model, iter)
File "/usr/lib/python2.7/site-packages/GMenuSimpleEditor/", line 177, in find_menu_file_parent
if model.get_value (iter, model.COLUMN_MENU_FILE):
File "/usr/lib/python2.7/site-packages/gi/overrides/", line 1196, in get_value
return self._decode_value(treeiter, column, value)
File "/usr/lib/python2.7/site-packages/gi/overrides/", line 803, in _decode_value
value = value.decode('UTF-8')
AttributeError: 'NoneType' object has no attribute 'decode'

Additional info:
* package version(s): gnome-menus
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 17 November 2012, 02:56 GMT
Reason for closing:  No response
Comment by kdas (kdas) - Sunday, 05 February 2012, 01:10 GMT
Confirmed here on fresh new install from net iso.
Comment by Greg (dolby) - Monday, 15 October 2012, 08:57 GMT
Still a problem with 3.4 or even 3.6?