Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27726 - [gvfs] New filesystem upgrade breaks gvfs trash functionality

Attached to Project: Arch Linux
Opened by Nathan Trapuzzano (nbtrap) - Monday, 26 December 2011, 19:37 GMT
Last edited by Allan McRae (Allan) - Saturday, 16 June 2012, 08:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: It seems that the latest upgrade to filesystem-2011.12-* has bro ken xdg trash functionality in the following sense:

Files and folders in .Trash-* directories on external volumes are not being incorporated into trash:///. These files and folders simply do not appear in the trash mount, and one must delete the files manually in order to permanently remove them (instead of "Emptying Trash").

Steps to reproduce:

1. Mount an external volume with Thunar or pcmanfm (or perhaps any other file manager--I haven't tested every one).
2. Delete a file and/or folder on that volume with the gvfs-trash command (or equivalent, e.g. right-click > delete).
3. Note that the file/folder does not appear in trash:/// even though it appears in .Trash-*/files on the external volume.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 16 June 2012, 08:27 GMT
Reason for closing:  No response
Comment by Allen (allencch) - Tuesday, 27 December 2011, 15:06 GMT
I have the same problem. I mounted the file manually with nautilus, after deleting the file, it has same problem as mentioned above. This problem exists on both pendrive with FAT32 and external harddisk NTFS.
Comment by Ionut Biru (wonder) - Tuesday, 27 December 2011, 15:23 GMT
technical detail about this issue:
- since filesystem-2011.12 /etc/mtab is a symlink to /proc/self/mounts.

Please report upstream about this issue asking to gain support for libmount. Don't forgot to paste the link so i can follow.

bugzilla.gnome.org, product gvfs
Comment by Nathan Trapuzzano (nbtrap) - Tuesday, 27 December 2011, 22:01 GMT
I'm not a dev, and I don't file bug reports often, so I'm not familiar with your lingo. By "report upstream" do you mean you want me to file a bug report with the gvfs devs? If so, it seems like that's already been done for this issue: https://bugzilla.gnome.org/show_bug.cgi?id=662946

I'm curious, however: how do you know this is a gvfs bug? The last gvfs [stable] update was back on 2011-10-20, and my trash worked fine for weeks afterward, so I suspect upgrading a different package more recently broke gvfs in this regard, though I've had an impossible time figuring out exactly which package. I suspected it was the latest filesystem upgrade, but I can't be sure of that, becase removing /etc/mtab (and letting the file get auto-generated as it was before it was incorporated into filesystem-2011.12-*) did not fix the issue.
Comment by Allen (allencch) - Wednesday, 28 December 2011, 07:57 GMT
Downgrade to filesystem-2011.10-1 does not solve the problem.
Comment by Gavin (Glinx) - Thursday, 05 January 2012, 20:59 GMT
..same problem here - will not empty trash on USB stick. Relying on Ubuntu 11.10 laptop to empty it!!
Comment by Nathan Trapuzzano (nbtrap) - Saturday, 07 January 2012, 19:28 GMT
Since filing this bug, I've switched to (KDE) Plasma and Dolphin, the only file manager I've found that does not have this problem (which isn't surprising given that it doesn't use gvfs). The bugginess of KDE has kept me away for years, but I must say, although I will continue to avoid most KDE apps like the plague, I am immensely impressed with Plasma and Dolphin. They've come a long way.

At any rate, this is very probably a gvfs bug.
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 13:16 GMT
Status?

Loading...