Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27674 - [qt] ignores fontconfig settings

Attached to Project: Arch Linux
Opened by Viktor (thesame) - Thursday, 22 December 2011, 20:42 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 11 January 2013, 06:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Qt ignores my font rendering settings configured in ~/.fonts.conf.
I have
<edit name="hinting" mode="assign">
<bool>false</bool>
</edit>
in fonts.conf, but fonts in Qt apps are hinted.

qt-4.8.0-2 ignores settings
qt-4.7.4-3 works well (as well as previous versions)

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 11 January 2013, 06:43 GMT
Reason for closing:  No response
Comment by Ivan Koryabkin (apathism) - Friday, 23 December 2011, 10:11 GMT
I don't have ~/.fonts.conf, but in /etc/fonts/local.conf hinting is turned off.
And font rendering in different apps is different.

For example, hinting is enabled in krunner, but it doesn't in ksysguard (see the screenshot).
   screen.png (158.8 KiB)
Comment by Martin Dratva (raqua) - Wednesday, 28 December 2011, 18:21 GMT
I have the similar/same problem.
To not write all here again, please look at this thread for details.
https://bbs.archlinux.org/viewtopic.php?pid=1033224
Comment by Andrea Scarpino (BaSh) - Wednesday, 28 March 2012, 19:28 GMT
Please try qt 4.8.1-1 and let me know.
Comment by Martin Dratva (raqua) - Sunday, 01 April 2012, 19:59 GMT
It seems to be fixed now on my machine, thank you.
Comment by Volodymyr (kolombo) - Saturday, 01 September 2012, 15:40 GMT
  • Field changed: Percent Complete (100% → 0%)
I still able to reproduce this bug with qt 4.8.2-3 on x86-64 arch.
Comment by Greg (dolby) - Saturday, 17 November 2012, 02:20 GMT
Is this still a problem? Did you try ~/.config/fontconfig/fonts.conf?

Loading...