Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27627 - [linux] no m-audio fasttrack pro support since kernel > 3.1.

Attached to Project: Arch Linux
Opened by norman (andana77) - Monday, 19 December 2011, 12:03 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 23 May 2012, 13:45 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

no fasttrack pro support anymore since kernel >3.1

something went wrong with code change!
https://lkml.org/lkml/2011/7/23/106


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
simpel just connect fasttrack pro under kernel >3.1 and some module is missing, so alsa doesnt list soundcard anymore.
with every kernel < 3.1 soundcard works fine! (i used linux-3.0.7-1-x86_64.pkg.tar.xz until now)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 23 May 2012, 13:45 GMT
Reason for closing:  No response
Comment by norman (andana77) - Monday, 19 December 2011, 12:05 GMT
sorry wrong category...should be kernel...sorry my first bugreport...
Comment by norman (andana77) - Monday, 19 December 2011, 12:14 GMT
log if needed:

(linux-3.1.5-1-x86_64)

archvaio pulseaudio[1196]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="0" name="usb-M-Audio_FastTrack_Pro-00-Pro" card_name="alsa_card.usb-M-Audio_FastTrack_Pro-00-Pro" namereg_fail=false tsched=yes ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
Comment by norman (andana77) - Monday, 19 December 2011, 12:19 GMT
tested on following kernel versions:

linux-3.1.1-1-x86_64
linux-3.1-4-x86_64
linux-3.1.5-1-x86_64
linux-3.0.7-1-x86_64 (here it works fine!)
Comment by norman (andana77) - Monday, 19 December 2011, 12:25 GMT
since kernel linux-3.1.5-1-x86_64, i can't downgrade anymore, cause of some nvidia prob says gdm ?!? thats why i decided "Severity: High"

i hope i have posted now all important details for fixing the problem!

thx also to all archfreaks out there! great system!
Comment by Thomas Bächler (brain0) - Friday, 13 January 2012, 15:27 GMT
Please try 3.2 from testing - if the bug is fixed there, things are much easier for us.
Comment by Ty John (sandman) - Friday, 27 January 2012, 00:08 GMT
I have the same issue with a M-Audio Fast Track (not pro). I just upgraded to 3.2.2 and the device still doesn't show up.
I am set up with pulseaudio and only a dummy device shows in pavucontrol.

In dmesg I get this when plugging the Fast Track in.
usb 1-2.1: new full-speed USB device number 7 using ehci_hcd

In lsusb it shows up as
Bus 001 Device 008: ID 0763:2024 Midiman

Finally, lsmod

[ty@donna ~]$ lsmod | grep snd
snd_hda_codec_hdmi 24121 4
snd_usb_audio 93493 0
snd_usbmidi_lib 18936 1 snd_usb_audio
snd_rawmidi 19458 1 snd_usbmidi_lib
snd_seq_device 5300 1 snd_rawmidi
snd_hda_codec_realtek 194997 1
snd_hda_intel 23343 0
snd_hda_codec 89160 3 snd_hda_intel,snd_hda_codec_realtek,snd_hda_codec_hdmi
snd_hwdep 6389 2 snd_hda_codec,snd_usb_audio
snd_pcm 74780 4 snd_hda_codec,snd_hda_intel,snd_usb_audio,snd_hda_codec_hdmi
snd_page_alloc 7153 2 snd_pcm,snd_hda_intel
snd_timer 19544 1 snd_pcm
snd 59214 11 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_seq_device,snd_rawmidi,snd_usbmidi_lib,snd_usb_audio,snd_hda_codec_hdmi
soundcore 6210 1 snd
usbcore 146241 8 ehci_hcd,xhci_hcd,ohci_hcd,usbhid,snd_usbmidi_lib,snd_usb_audio,uvcvideo
Comment by Tobias Powalowski (tpowa) - Saturday, 28 April 2012, 08:20 GMT
status on 3.3 series?

Loading...