Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#27611 - pacman -Sdd do a conflict check

Attached to Project: Pacman
Opened by Sébastien Luttringer (seblu) - Saturday, 17 December 2011, 23:10 GMT
Last edited by Allan McRae (Allan) - Saturday, 09 February 2013, 03:46 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

Option -d or --nodeps of pacman -S should ignore depends and conflict depends as said in man page.

-d, --nodeps
Skips dependency version checks. Package names are still checked. Normally, pacman will always check a
package’s dependency fields to ensure that all dependencies are installed and there are no package
conflicts in the system. Specify this option twice to skip all dependency checks.

Steps to Reproduce:
1) Install cpupower (it will conflict with cpufrequtils)
2) try to install cpufrequtils with pacman -Sfdd cpufrequtils

# pacman -Sddf cpufrequtils
looking for inter-conflicts...
:: cpufrequtils and cpupower are in conflict. Remove cpupower? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: cpufrequtils and cpupower are in conflict
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 09 February 2013, 03:46 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Dependency != conflict
Comment by Allan McRae (Allan) - Saturday, 17 December 2011, 23:19 GMT
Where does the man page say -dd ignores conflicts?
Comment by Ionut Biru (wonder) - Saturday, 17 December 2011, 23:31 GMT
-f fixes everything! </ironic>

Comment by Sébastien Luttringer (seblu) - Sunday, 18 December 2011, 00:02 GMT
1) Normally, pacman will always check a package’s dependency field_s_
=> depends, optdepends are dependency fields (by definition). Maybe conflict is a dependency field?
2) to ensure that all dependencies are installed and there are no package
conflicts in the system
=> ok, they check depency fields to check install depends _and_ conflict, so conflict is a dependency field.
3) Specify this option twice to skip all dependency checks
=> -dd should skip conflict parameter.

That's was the path in my mind. Maybe i misunderstood the mean of dependency inside it.

Loading...