Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27572 - kernel 3.1.5 suspent disk/ram freezes system

Attached to Project: Arch Linux
Opened by Heinrich Siebmanns (Harvey) - Wednesday, 14 December 2011, 14:07 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 04 January 2012, 13:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Since the update to kernel 3.1.5 my system is not able to suspend to ram (or disk) anymore. System goes down but the wake up process hangs with a black screen. Only hard reset (!) can get me out here. Can't even change to another tty with ctrl-alt-Fx
Additional info:
https://bbs.archlinux.org/viewtopic.php?pid=1028296#p1028296
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 04 January 2012, 13:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.1.7-1
Comment by Justin (jusko) - Wednesday, 14 December 2011, 17:05 GMT
Experiencing the same issue after upgrading to stock kernel 3.1.5-1 today. Problem occurs with both fglrx and xf86-video-ati drivers for me (the case in the bbs link above was with an nvidia card btw; so graphics card seems innocent this time;).

System (attached dmidecode and lspci dump in system-spec-01.txt, though doubt it's of use)
------------------------------------------------------------------------------------------

CPU: Core i7 840QM
GPU: Radeon HD5870 Mobility
MEM: 4041516k total
Swap: 4498196k total
Boot: kernel /vmlinuz-linux root=/dev/mapper/cryptroot cryptdevice=/dev/sda3:cryptroot ro quiet resume=/dev/sda2 radeon.modeset=1 radeon.agpmode=-1

Attached diff of pm-suspend.log in the last successful case (on kernel 3.1.4) vs a failed resume (on 3.1.5). Nothing immediately strikes me as odd; but perhaps someone with more kernel module know how might detect something.

Other than that, there is no trace of errors in the logs which means the lock occurs before syslog is back up.

Happy to test this one further so just say the word.
Comment by Filippo cucchetto (Cuke) - Wednesday, 14 December 2011, 19:09 GMT
I can confirm this. Same issue i reported 27563 with my acer 5943g. Revert to 3.1.4 solved.
There's no mention in the pm-suspend log of the resume procedure...maybe it isn't executed at all.
I tried it also with modesetting off..so i think it's not video card related.
However there two config supplied by two kernel are the same ..

i think we can merge  bug 27563  https://bugs.archlinux.org/task/27563?project=1 with this one

I attach my lspci
Comment by Hidesato Ikeya (BonBaba) - Thursday, 15 December 2011, 09:50 GMT
I have reported this issue on ArchLinux bbs, but will write it down here with additional infomation.
After updating to kernel 3.1.5, my system fails resume from suspend-to-RAM.
My display got turned on automatically, but the screen remains black.
However, fan speed of my Nvidia graphics card properly drops and becomes quiet.
If system failed to load display driver, the fan speed would be max and very noisy, so I think display driver is successfully loaded.
I'm not sure but this issue might relate to Intel 3400 Series Chipset.

My system
------------------------------------
CPU: Core i7 860
GPU: Nvidia Geforce GTS 250
MEM: 8173036 total
Swap: 19583196 total
Boot: kernel /boot/vmlinuz-linux root=/dev/sdb2 resume=/dev/sdb7 ro
Comment by Martin Corley (martinc) - Thursday, 15 December 2011, 13:21 GMT
I can confirm this problem (same symptoms as above)

CPU: Core Duo E8400
GPU: Mobility Radeon HD 3470
MEM: 3921916 total
Swap: 2097148 total
Boot: kernel /vmlinuz-linux root=/dev/mapper/VolGrp00-ROOT64 resume=/dev/mapper/VolGrp00-SWAP ro nomodeset
Comment by Heinrich Siebmanns (Harvey) - Sunday, 18 December 2011, 12:44 GMT
My system suspends again.
Here is what I did: My system's BIOS has in 'Power Management Setup' an option 'HPET support' (high precision timer support) which can be set 32bit, 64bit or disabled. If disabled, the suspend works with kernel 3.1.5. Maybe the kernel cracks can guess now where all the trouble comes from.
Comment by Filippo cucchetto (Cuke) - Sunday, 18 December 2011, 15:17 GMT
Heinrich i tried to suspend disabling the hyper threading adding the noht option at grub and suspend didn't work anyway!
Comment by Linus Zielony (Zielony) - Tuesday, 20 December 2011, 15:25 GMT
I have the same problem here after upgrading to 3.1.5. When I wake the system up, on 7th tty I got black screen instead of X and on the rest I can type the login, but it doesn't ask me for a password.

CPU: Core i5 750
GPU: nVidia GeForce 8400 GS

I attach my lspci and dmidecode.
Comment by Giuseppe Borzi (gborzi) - Friday, 23 December 2011, 10:06 GMT
I have the same problem and found a workaround, based on the last post from Harvey here https://bbs.archlinux.org/viewtopic.php?id=131827. HPET can be disabled by software, adding hpet=disable to the kernel parameters line. My grub kernel line now reads

kernel /vmlinuz-linux root=/dev/sda5 ro resume=/dev/sda2 vga=0 hpet=disable

this fixed the problem.

Hope this helps.
Comment by Heinrich Siebmanns (Harvey) - Friday, 23 December 2011, 13:59 GMT
Just in case someone is interested: there is a patch concerning hpet failures in kernel 3.1.6 but it does NOT help for me. With hpet enabled my system still freezes when suspending...
Comment by Hidesato Ikeya (BonBaba) - Saturday, 24 December 2011, 05:32 GMT
I have included hpet=disable in my kernel line too and suspend has got to work!
Thank you!
Comment by Justin (jusko) - Saturday, 24 December 2011, 08:27 GMT
hpet=disable solves for me too.
Comment by James Hunt (brandnewmath) - Saturday, 24 December 2011, 08:29 GMT
The hpet=disable workaround allows me to suspend successfully also using pm-suspend. I'm still hoping for a proper fix from upstream, naturally.
Comment by Calycé (calyce) - Tuesday, 27 December 2011, 14:07 GMT
hpet=disable is working for me too
Comment by Dennis Groenen (iDont) - Saturday, 31 December 2011, 10:32 GMT
Resuming from suspend also results in a freeze on my laptop (Core i7 820qm).
Either downgrading to kernel 3.1.4 or disabling hpet 'fixes' the issue.
Comment by John Henderson (jwhendy) - Saturday, 31 December 2011, 22:38 GMT
Just to confirm the "hpet=disable" workaround. This works for me on an HP8540w with nvidia graphics with default Arch 3.1.5 kernel.
Comment by Sebastian (H-Bloxx) - Monday, 02 January 2012, 11:15 GMT
Experiencing the same issue but hpet=disable didn't solved it for me. Also there ist no BIOS option for this on my Thinkpad W510.
Comment by Calycé (calyce) - Monday, 02 January 2012, 13:11 GMT
The problem still exists with kernel 3.1.6-1-ARCH but fortunately the "hpet=disable" workaround continues to work.
Comment by Hidesato Ikeya (BonBaba) - Monday, 02 January 2012, 14:29 GMT
Same here. Kernel 3.1.6-1 doesn't solve the problem.
Comment by Heinrich Siebmanns (Harvey) - Wednesday, 04 January 2012, 11:27 GMT
kernel 3.1.7 fixes this for me. They reverted 'clockevents' which seems to be the culprit here.
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.1.7

Loading...