Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27556 - [clucene] pkgconfig does not list all required libraries

Attached to Project: Community Packages
Opened by Alex Merry (pippin) - Tuesday, 13 December 2011, 19:26 GMT
Last edited by Alexander F. Rødseth (xyproto) - Tuesday, 17 January 2012, 11:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
clucene's pkgconfig file only lists clucene-core as a library that needs linking to. However, clucene-shared is also required (for the lucene::util::atomic_threads::atomic_decrement symbol, for example).

Previously, this would be dragged in automatically, since it is linked by clucene-core, but the behaviour of ld has apparently been changed to not do this any more.

Additional info:
* package version(s)
clucene 2.3.3.4-1
binutils 2.22-2
* config and/or log files etc.


Steps to reproduce:
Try to compile libstreamanalyzer from KDE's git repos, for example.
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Tuesday, 17 January 2012, 11:21 GMT
Reason for closing:  Fixed
Comment by Alex Merry (pippin) - Tuesday, 13 December 2011, 19:27 GMT
Output from compiling libstreamanalyzer:

/usr/bin/ld: CMakeFiles/index2dump.dir/indexdump.cpp.o: undefined reference to symbol 'lucene::util::atomic_threads::atomic_decrement(unsigned int*)'
/usr/bin/ld: note: 'lucene::util::atomic_threads::atomic_decrement(unsigned int*)' is defined in DSO /usr/lib/libclucene-shared.so.1 so try adding it to the linker command line
/usr/lib/libclucene-shared.so.1: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
Comment by Andrea Scarpino (BaSh) - Tuesday, 13 December 2011, 19:37 GMT
I don't know if there is a bug in clucene, anyway you don't need clucene in strigi (see https://trueg.wordpress.com/2011/09/22/about-strigi-soprano-virtuoso-clucene-and-libstreamanalyzer/) use -DENABLE_CLUCENE=OFF -DENABLE_CLUCENE_NG=OFF when building libstreamanalyzer.
Comment by Alexander F. Rødseth (xyproto) - Sunday, 18 December 2011, 22:42 GMT
Is there a PKGBUILD available for libstreamanalyzer? I can confirm that the tip from Andrea Scarpino works, and makes libstreamanalyzer compile.

Is this really a packaging bug, or should this be reported upstream?
Comment by Alexander F. Rødseth (xyproto) - Thursday, 22 December 2011, 00:06 GMT Comment by Alexander F. Rødseth (xyproto) - Tuesday, 17 January 2012, 11:21 GMT
I applied a fix to the .pc file in the PKGBUILD in subversion, will release the updated package soon.

Loading...