Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27551 - [scribes] does not run as non-root user

Attached to Project: Community Packages
Opened by j. ceasless (jceasless) - Tuesday, 13 December 2011, 15:34 GMT
Last edited by Jelle van der Waa (jelly) - Saturday, 25 May 2013, 20:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Scribes community package runs as root user, but fails to load for non-root users.

Additional info:
* package version(s)

scribes 0.4.954-1

* config and/or log files etc.

scribes-traceback: traceback output when trying to run scribes as non-root user.


Steps to reproduce:

1) Install scribes from [community]
2) Attempt to run scribes as non-root user
This task depends upon

Closed by  Jelle van der Waa (jelly)
Saturday, 25 May 2013, 20:34 GMT
Reason for closing:  No response
Comment by j. ceasless (jceasless) - Tuesday, 13 December 2011, 17:56 GMT
In fact Scribes is also broken for root user. See the file 'root-traceback' or here: https://bbs.archlinux.org/viewtopic.php?id=131485

Applied the 'from sys import executable pattern' outlined in in https://bbs.archlinux.org/viewtopic.php?pid=925844#p925844 to SCRIBES/Globals.py. The attached files accomplish this.

However, the errors persist unchanged.

I am going to go for a more complete recreation of konradstrack's patches.
Comment by j. ceasless (jceasless) - Tuesday, 13 December 2011, 19:04 GMT
Did a full fix for every usage of __python_executable = join(prefix, "bin", "python").

Still no effect on running as non-root user.

With root only one error message:

'/usr/lib/python2.7/site-packages/SCRIBES/Main.py:10: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
main()'
Comment by Jaroslav Lichtblau (Dragonlord) - Sunday, 18 December 2011, 18:31 GMT
Did you try to remove ~/.config/scribes before starting the application?
Scribes starts on my system and is usable. In terminal, I get:

/usr/lib/python2.7/site-packages/SCRIBES/Main.py:10: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
main()
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/RecentOpen/ExternalProcess/ScribesRecentFilesIndexer.py", line 8, in <module>
from gobject import MainLoop, threads_init
File "/usr/lib/python2.7/site-packages/gobject/__init__.py", line 26, in <module>
from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
File "/usr/lib/python2.7/site-packages/glib/__init__.py", line 22, in <module>
from glib._glib import *
ImportError: /usr/lib/libpyglib-2.0-python2.so.0: undefined symbol: _Py_ZeroStruct
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/SuggestionProcess/ScribesWordCompletionSuggestionGenerator.py", line 5, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils
Traceback (most recent call last):
File "/usr/lib/scribes/GenericPlugins/WordCompletion/IndexerProcess/ScribesWordCompletionIndexer.py", line 3, in <module>
from SCRIBES.Utils import fork_process
ImportError: No module named SCRIBES.Utils
Comment by Jelle van der Waa (jelly) - Saturday, 17 November 2012, 12:36 GMT
It works for me with a fresh install
Comment by Ray Rashif (schivmeister) - Tuesday, 12 February 2013, 10:04 GMT
I cannot reproduce this - it starts up and works fine for me.

Loading...