Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27520 - [akonadi] doesn't properly create its mysql database

Attached to Project: Arch Linux
Opened by Jakub Schmidtke (sjakub) - Saturday, 10 December 2011, 15:55 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 02 February 2013, 18:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I have had problems with Akonadi recently and started investigating the issue.
It looks like the mysql database created by Akonadi is broken.
I was seeing several errors in ~/.local/share/akonadi/db_data/mysql.err (it can be also
accessed through akonadiconsole, and using the "Test" function in the Server's configuration page).

I don't have the log file since I fixed the issue, but it had entries like:
Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
[ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
[ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
and several more like this.

I thought I could use mysql_upgrade to fix that, but it was complaining about missing "mysql" database.
I found this topic: https://bbs.archlinux.org/viewtopic.php?id=78358 which suggests
removing ~/.local/share/akonadi/db_data/ and running:
mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/
to manually create the DB. I removed that directory and tried running the command, but it was returning an error:
FATAL ERROR: Could not find ./bin/my_print_defaults

To fix that I had to add following option: --basedir=/usr
With basedir specified it works fine. But I thought that maybe I should allow Akonadi create the DB
itself, since it might be doing things differently. So I removed the DB directory again, and just started the Akonadi.
It created the DB, but it was broken again - and in the log file produced by "akonadictl start"
I saw a message about missing my_print_defaults.

So I ended up removing everything again, creating the DB myself, and running akonadi on top of that.
Now it works fine and doesn't complain anymore about broken mysql DB.

So it looks like Akonadi doesn't run mysql_install_db properly. I'm not sure why, maybe it's a problem with
Akonadi itself, or maybe just with some build options or Arch-specific paths?

Versions:
akonadi 1.6.2-2
libmysqlclient 5.5.19-1
mysql 5.5.19-1
mysql-clients 5.5.19-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 02 February 2013, 18:06 GMT
Reason for closing:  Upstream
Additional comments about closing:  Closed as upstream have to take care of this
Comment by Andrea Scarpino (BaSh) - Sunday, 18 December 2011, 18:09 GMT
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 17 August 2012, 21:27 GMT
  • Field changed: Status (Assigned → Waiting on Response)
status?

Loading...