Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27456 - syslinux cannot find mcopy

Attached to Project: Arch Linux
Opened by Marcel Korpel (Marcel-) - Monday, 05 December 2011, 14:06 GMT
Last edited by Eric Belanger (Snowman) - Friday, 09 December 2011, 12:19 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After performing steps 1–3 of [1] I tried to create a bootable USB stick using

# syslinux /dev/sdc1

I get the following errors:

sh: mcopy: command not found
syslinux: failed to create ldlinux.sys

(/dev/sdc1 is a valid VFAT formatted partition)

[1] http://www.sysresccd.org/Sysresccd-manual-en_How_to_install_SystemRescueCd_on_an_USB-stick#E.29_Manual_installation_from_Linux_using_cp_.28deprecated.29

Additional info:
* package version: 4.04-2

Steps to reproduce:

Follow the steps at [1] above. When issuing the last step, the above error message shows up.
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 09 December 2011, 12:19 GMT
Reason for closing:  Not a bug
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 05 December 2011, 14:18 GMT
Optional Deps : perl-passwd-md5: For md5pass
perl-digest-sha1: For sha1pass
mtools: For mkdiskimage and syslinux
Comment by Marcel Korpel (Marcel-) - Monday, 05 December 2011, 14:20 GMT
Whoops, sorry, I think I missed that.
Comment by Jan de Groot (JGC) - Monday, 05 December 2011, 14:31 GMT
What's the point of making mtools optdepends if it's needed for the main binary to work?
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 05 December 2011, 14:37 GMT
Because syslinux is not the main binary.

syslinux is used on unmounted media, while extlinux is used on mounted media. They both are the same bootloaders (ldlinux.sys) since version 4.00.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 06 December 2011, 04:53 GMT
DUP:  FS#20875   FS#21605   FS#22627 

Loading...