Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27422 - Deadbeef 0.5.1 doesn’t support ffmpeg-20111123-1

Attached to Project: Community Packages
Opened by Marty (vadmium) - Saturday, 03 December 2011, 04:31 GMT
Last edited by Lukas Fleischer (lfleischer) - Wednesday, 25 January 2012, 08:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The new -3 build depends on a new FFMPEG library but it seems Deadbeef 0.5.1 uses "av_register_protocol", which is missing from the new FFMPEG version.

Related forum posts: https://bbs.archlinux.org/viewtopic.php?pid=1023637#p1023637

Probably best solutions might be to try patching more from these upstream commits:
https://deadbeef.git.sourceforge.net/git/gitweb.cgi?p=deadbeef/deadbeef;a=commitdiff;h=2bb5828e58fa8c187377f8ba75f8eb73a53ed7ca
https://deadbeef.git.sourceforge.net/git/gitweb.cgi?p=deadbeef/deadbeef;a=commitdiff;h=2bb5828e58fa8c187377f8ba75f8eb73a53ed7ca

Otherwise you’d probably have to build against a previous FFMPEG.

Additional info:
* package version(s): deadbeef-0.5.1-3, ffmpeg-20111123-1
* config and/or log files etc.

Plugin messages:
loading plugin /usr/lib/deadbeef/ffmpeg.so
dlopen error: /usr/lib/deadbeef/ffmpeg.so: undefined symbol: av_register_protocol
trying /usr/lib/deadbeef/ffmpeg.fallback.so...
plugin not found or failed to load
[dlopen message not normally enabled]

Compiler messages:
libtool: compile: gcc . . . -c ffmpeg.c . . .
[whole lot of deprecation warnings]
ffmpeg.c: In function 'ffmpeg_start':
. . .
ffmpeg.c:717:5: warning: implicit declaration of function 'av_register_protocol' [-Wimplicit-function-declaration]
. . .

Steps to reproduce:

Compile deadbeef, notice undeclared function warning
Start deadbeef (from terminal), notice FFMPEG plugin failure
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Wednesday, 25 January 2012, 08:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.5.1-4.
Comment by Lukas Fleischer (lfleischer) - Thursday, 08 December 2011, 23:01 GMT
Is there any reason you added two links to the very same commit? :)
Comment by Marty (vadmium) - Thursday, 08 December 2011, 23:43 GMT
It was a mistake. The second one was meant to be 9cbd09b81028679a507f751c206e8f6769fd450c “ffmpeg: version check fix”. I was just looking at the recent history in that ffmpeg.c file.
Comment by Lukas Fleischer (lfleischer) - Wednesday, 25 January 2012, 07:15 GMT
9cbd09b81028679a507f751c206e8f6769fd450c looks like the right fix.

Marty: Could you please test the patched package [1], [2] I created? Just to be sure that patch actually fixed what you were seeing :)

[1] http://cryptocrack.de/tmp/deadbeef-0.5.1-4-i686.pkg.tar.xz
[2] http://cryptocrack.de/tmp/deadbeef-0.5.1-4-x86_64.pkg.tar.xz
Comment by Marty (vadmium) - Wednesday, 25 January 2012, 07:50 GMT
I tested your -4 x86-64 version. There was no “failed to load” message and there is an FFMPEG entry listed under “plugins” in the preferences, so I think you fixed it.
Comment by Lukas Fleischer (lfleischer) - Wednesday, 25 January 2012, 08:18 GMT
I just pushed 0.5.1-4 to [community]. Thanks for testing!

Loading...