Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27348 - [gettext] Repository package content differs from manual build

Attached to Project: Arch Linux
Opened by Alexander Meshcheryakov (Self-Perfection) - Wednesday, 30 November 2011, 15:59 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 30 November 2011, 17:09 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
It seemed to me that gettext package are too large because of unneded 3.4 MB usr/share/gettext/archive.dir.tar.gz file

I tried to recomple package from official PKGBUILD (http://projects.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/gettext) and, surprisingly, the result does not contain archive.dir.tar.gz and in much smaller in .pkg.tar.xz - just 2MB vs 5 MB package from repo. To be precise, difference in file list is:

Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/lib/gettext: msgfmt.net.exe
Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/lib/gettext: msgunfmt.net.exe
Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/lib: GNU.Gettext.dll
Only in /tmp/gettext-0.18.1.1-4/usr/share/gettext: archive.dir.tar.gz
Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/share/gettext: archive.git.tar.gz
Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/share/gettext: gettext.jar
Only in /tmp/yaourt-tmp-self/gettext/pkg/usr/share/gettext: libintl.jar


Also there is remarkable difference in usr/bin/autopoint

diff -ur /tmp/gettext-0.18.1.1-4/usr/bin/autopoint /tmp/yaourt-tmp-self/gettext/pkg/usr/bin/autopoint
--- /tmp/gettext-0.18.1.1-4/usr/bin/autopoint 2011-11-04 15:46:14.000000000 +0400
+++ /tmp/yaourt-tmp-self/gettext/pkg/usr/bin/autopoint 2011-11-30 15:49:09.169077151 +0400
@@ -173,7 +173,7 @@
func_version ()
{
echo "$progname (GNU $package) $version"
- echo "Uses a versions archive in dir format."
+ echo "Uses a versions archive in git format."
echo "Copyright (C) 2002-2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
@@ -386,7 +386,7 @@
# git | 484 | git |
# -------+-----------------------------+--------------------+

-case "dir" in
+case "git" in
dir)
# The archive of different versions is very large, but using it does not
# require special tools.



This strange. Probably, parameters for configure script should be more precise.

Additional info:
* package version(s)
0.18.1.1-1
0.18.1.1-3
0.18.1.1-4
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 30 November 2011, 17:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See my comment
Comment by Andrea Scarpino (BaSh) - Wednesday, 30 November 2011, 16:53 GMT
Confirmed.
$ ls -l /tmp/gettext-0.18.1.1-5-x86_64.pkg.tar.xz
-rw-r--r-- 1 bash users 2074500 Nov 30 17:50 /tmp/gettext-0.18.1.1-5-x86_64.pkg.tar.xz
$ ls -l /var/cache/pacman/pkg/gettext-0.18.1.1-4-x86_64.pkg.tar.xz
-rw-r--r-- 1 root root 5178092 Nov 4 12:48 /var/cache/pacman/pkg/gettext-0.18.1.1-4-x86_64.pkg.tar.xz

$ checkpkg
usr/share/gettext/archive.dir.tar.gz | usr/share/gettext/archive.git.tar.gz
> usr/share/gettext/gettext.jar
> usr/share/gettext/libintl.jar

EDIT:
rebuilding with --disable-java and --without-git I got the same gettext binary that's in [core].
We build packages in clean chroots and those flags are set to "automatic", I don't know if we should disable it or not, but of course we don't want gettext to depend on git or java.

Loading...