Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27334 - [mkinitcpio] mkinitcpio fails when updating linux package with yaourt -Syu

Attached to Project: Arch Linux
Opened by Gilles Habran (hiveNzin0) - Tuesday, 29 November 2011, 19:42 GMT
Last edited by Eric Belanger (Snowman) - Thursday, 01 December 2011, 11:24 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi guys,

every time I update the linux kernel with yaourt -Syu (to be honest, I didn't try with pacman, I will try next time I see there is an update for linux package), mkinitcpio fails with this error : /tmp/alpm_i7hwO9/.INSTALL: line 56: depmod: command not found (Please find attached the terminal output).

To solve this issue, I have to "manually" install the linux kernel (yaourt|pacman -S linux), after that mkinitcpio works fine.

I selected Critical for the Severity because if I don't pay attention while updating my system and reboot, I can't use the kernel, I have to boot from a arch live CD, chroot and install linux manually (as explained above).

Thanks. :)

This task depends upon

Closed by  Eric Belanger (Snowman)
Thursday, 01 December 2011, 11:24 GMT
Reason for closing:  Not a bug
Comment by Karol Błażewicz (karol) - Tuesday, 29 November 2011, 20:42 GMT
> I selected Critical for the Severity because if I don't pay attention while updating my system and reboot
There are plenty of warnings in the output you posted.
Comment by Gilles Habran (hiveNzin0) - Tuesday, 29 November 2011, 20:44 GMT
Yeah I know but still. It breaks the system if not fixed before rebooting. :)

Can I edit my post ?
Comment by Jan de Groot (JGC) - Wednesday, 30 November 2011, 00:14 GMT
Yaourt is unsupported. Probably /sbin is missing from your PATH when you're installing things from yaourt. Please retry with pacman instead.
Comment by Gilles Habran (hiveNzin0) - Wednesday, 30 November 2011, 06:02 GMT
/sbin was missing indeed. Thank you. I will try and post an update next time linux has to be updated to see if things changed.

Comment by Gilles Habran (hiveNzin0) - Thursday, 01 December 2011, 09:19 GMT
Okay, it worked fine with /sbin in my PATH.

Sorry for this.

Loading...