Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27252 - [maven] Do not set M2_HOME

Attached to Project: Community Packages
Opened by Julien Nicoulaud (nicoulaj) - Friday, 25 November 2011, 17:40 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 01 December 2011, 13:47 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The package installs a script at /etc/profile.d/maven.sh that exports the M2_HOME environment variable. This variable is not needed for Maven to work properly and causes the package to conflict with other standalone installations/AUR packages of Maven 2.

Additional info:
* package version: 3.0.3

Steps to reproduce:
Download and extract a Maven 2 tar.gz, execute bin/mvn, and a Java stack trace appears, because it tries to use M2_HOME from the environment.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 01 December 2011, 13:47 GMT
Reason for closing:  Fixed

Loading...