Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27231 - [ozerocdoff] udev rules conflict

Attached to Project: Community Packages
Opened by Tom (hungerfish) - Wednesday, 23 November 2011, 12:12 GMT
Last edited by Sergej Pupykin (sergej) - Saturday, 07 January 2012, 11:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since a recent update (22.11.11) I'm getting following messages during bootup:

Tue Nov 22 19:52:06 2011: :: Loading User-specified Modules [BUSY] udevd[240]: unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/51-hso-udev.rules:73
Tue Nov 22 19:52:06 2011:
Tue Nov 22 19:52:06 2011: udevd[240]: invalid rule '/etc/udev/rules.d/51-hso-udev.rules:73'
Tue Nov 22 19:52:06 2011:
Tue Nov 22 19:52:06 2011: udevd[240]: unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/51-hso-udev.rules:76
Tue Nov 22 19:52:06 2011:
...
Tue Nov 22 19:52:06 2011: udevd[240]: unknown key 'SYSFS{hsotype}' in /etc/udev/rules.d/51-hso-udev.rules:105
Tue Nov 22 19:52:06 2011:
Tue Nov 22 19:52:06 2011: udevd[240]: invalid rule '/etc/udev/rules.d/51-hso-udev.rules:105'
...
Tue Nov 22 19:52:06 2011: udevd[240]: invalid rule '/etc/udev/rules.d/51-hso-udev.rules:115'
...
Tue Nov 22 19:52:06 2011: udevd[240]: NAME="%k" is ignored, because it breaks kernel supplied names, please remove it from /etc/udev/rules.d/51-hso-udev.rules:124

ozerocdoff was installed as a dependency for comgt, but despite this error during boot up, I can still use my usb-modem.

Additional info:
* package version(s)
2-3 - ozerocdoff
175-1 - udev
* config and/or log files etc.
See attachment for complete error-log taken from /var/log/boot


Steps to reproduce:
Install recent arch-linux, and comgt (https://aur.archlinux.org/packages.php?ID=6736) which pulls this package.
Reboot.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Saturday, 07 January 2012, 11:52 GMT
Reason for closing:  Fixed
Comment by Dave Reisner (falconindy) - Monday, 28 November 2011, 01:34 GMT
Additionally, this package shouldn't be writing rules to /etc/udev/rules.d. It's upstream's fault, but we should be fixing it (and reporting it upstream).... except that upstream is a forum post from 3 years ago. awesome.

Loading...